[mythtv-users] seeking/editing in mythfrontend

Leo Butler leo.butler81 at googlemail.com
Sat Mar 27 14:33:18 UTC 2021

John Pilkington <johnpilk222 at gmail.com> writes:

> On 27/03/2021 01:50, Leo Butler via mythtv-users wrote:
>> I transcode my recordings to an x264-encoded video stream in a matroska
>> container. I use ffprobe to update the recordedseek table after
>> transcoding. I have been doing this for a couple years.
>> In both v0.28 and v0.29 (from the mythbuntu ppa), I was able to seek
>> and
>> edit these mkv files without difficulty. In v0.31/fixes from the same
>> ppa, seeking and editing is broken for these transcoded files--it
>> appears that any movement in the video is only by a keyframe. Playback
>> is fine.
>> Seeking and playback in fine in vlc and ffplay, fwiw.
>> This seems like a regression to pre v0.28 behaviour.
>> Has anyone seen similar behaviour? Suggestions on how to workaround
>> the
>> problems? Ideas about what caused the regression?
>> TIA,
>> Leo
> ... replying to your original question:  have you tried the different
> decoder options (Frontend Setup > Video > Playback) when trying to do 
> precision editing?  I don't know how many of the changes there in the
> last year have reached your setup.

I don't see anything relevant there.

Maybe I didn't make myself clear, though. The problem that I am having
is this:

-I can create a seektable for a transcoded recording which mythtv
 recognizes and understands;

-During playback, I can try to seek forward or backward. Mythfrontend
 records the changed location on its information bar, but the playback
 remains at the same spot in the file.

-Similar behaviour occurs when I enter the editor.

Before the upgrade, in v0.29, both seeking and editing worked
'naturally' for these transcoded files.


More information about the mythtv-users mailing list