[mythtv-users] HD playback problem w/ kernel version

John Pilkington johnpilk222 at gmail.com
Mon Feb 11 21:51:53 UTC 2019

On 11/02/2019 20:56, Mark Brown wrote:
> Hey, sorry for the delay in responding.  I booted my fc29 front end to 
> kernel 4.20.6-200 and hd playback was still severely choppy.  I verified 
> that mythfrontend is indeed using vaapi (m > playback > playback data), 
> but playback still suffers.  Changed vid scan to progressive as you 
> suggested, and it improved playback some, but still to choppy to live 
> with.  Rebooted fc 29 front end to kernel 4.18.16-300, and all is well 
> again, all playback is smooth and works fine.  For me the problem began 
> late in fc28 when the first kernel 4.19 came on the scene.  I upgraded 
> the front end to fc29, but that again only works great when its using 
> the 4.18 series kernel.  Id be interested in what you see if you put the 
> 4.18 kernel on your fresh fc29 laptop and see if your playback is 
> improved...
> Thanks,
> -M

I tried google with 'vaapi kernel 4.20 bugzilla' and first hit was


which appears to have been festering since 2005 and is now at comment 
987.  Many comments are long.  Baytrail, probably not the N2380...

John P
> On Sat, Feb 9, 2019 at 7:48 AM Tim Draper <veehexx at zoho.com 
> <mailto:veehexx at zoho.com>> wrote:
>       ---- On Tue, 05 Feb 2019 13:56:26 +0000 Mark Brown
>     <mbrown at wheelgroup.org <mailto:mbrown at wheelgroup.org>> wrote ----
>       > Hello all,
>       > Been having HD playback problems with a Fedora 28/29 frontend
>     since kernel 4.19.  The problem exists with HD TV (hdhr) or HD video
>     playback.
>       > Frontend version is 29.1-25 and is on an intel nuc, i915 video
>     chipset, hdmi out, 'Option "AccelMethod" "sna"' is set, "VAAPI 
>     normal" enabled in mythfrontend.
>       > System works fantastic with kernel versions up to 4.18.16-300
>     but anything later in the 4.19/4.20 series and HD playback stutters
>     terribly (audio and video).
>       > Anyone seeing similar or have a pointer of where to look?
>       > Thanks! -mark _______________________________________________
>       > mythtv-users mailing list
>       > mythtv-users at mythtv.org <mailto:mythtv-users at mythtv.org>
>       > http://lists.mythtv.org/mailman/listinfo/mythtv-users
>       > http://wiki.mythtv.org/Mailing_List_etiquette
>       > MythTV Forums: https://forum.mythtv.org
>       >
>     you might be onto something here. i too have been having issues.
>     when in a HD recording, try menu > video > advanced > video scan >
>     manually set 'Progressive'. and see if that improves things.
>     just tried it on my recently rebuilt FC29 laptop - out of box works
>     fine. aside from the fact vaapi isnt enabled on FC29 iso, you have
>     to manually install the libva-intel-drivers (and libva-tools why
>     not; 'sudo vainfo' to confirm operation) enable the VAAPI decoder in
>     mythtv video playback settings and things go wrong.
>     also had it on primary FE (see thread 'v30 unsmooth playback'
>     recently) and a reinstall seems to have fixed it. turns out it could
>     be i dont have the vaapi drivers installed on it.

More information about the mythtv-users mailing list