[mythtv] 20180705 Android Observations

John P Poet jppoet at gmail.com
Fri Jul 6 15:17:38 UTC 2018


On Thu, Jul 5, 2018 at 8:55 PM David Engel <david at istwok.net> wrote:

> Peter,
>
> Here are my initial observations using your 20180705 patch.
>
> <snip>

>
> 1080i played fairly well.  Video was slightly stuttery at 1x and more
> noticeably at all faster speeds up to and including 2x.  Skips were a
> little slower than hoped for but still okay.  The main problem with
> skips was there was almost always a brief flicker of what looked to be
> a misaligned frame.
>

A little bit of a tangent...

My local CBS and FOX stations are now both on the same transport -- 13.1
(1080i) and 13.2 (720p).  In addition, they have added another SD channel
at 13.3.  All jammed into 19 mbit.  The result is that the quality of those
channels is pathetic to say the least.

When using VDPAU for decoding those mpeg2 stream, I now get lots of
pixelization when watching CBS and some when watching FOX.  I have found
that I can get rid of the pixelization if I use VDPAU for the renderer but
Standard for the decoder.  ffmpeg seems to be much more tolerant of the
errors than VDPAU.

When using the standard (ffmpeg) decoder, though, I do see "residue" frames
being shown (flickering) when jumping to another position.  This does not
happen when using VDPAU for decoding.  It sounds like this the same same
thing that David is seeing on the Shield.  I figured I would relay this
story just in case it helps to understand the issue.

John
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-dev/attachments/20180706/9d45565e/attachment.html>


More information about the mythtv-dev mailing list