[mythtv-users] Web interface scalability issue: Video Gallery

Peter Bennett pb.mythtv at gmail.com
Sun Sep 3 21:08:57 UTC 2023


On 9/3/23 13:56, Jan Ceuleers wrote:
> Dear all,
>
> I am a mythweb user of many years, but clearly I will need to start
> using the new alternative on port 6544 some time soon.
>
> So I took a look and I noticed that the Video Gallery takes very long to
> appear. Meanwhile the backend is maxed out on one core.
>
> I have quite an extensive collection of movies and series, consisting of
> 5429 files that are located on 4 SSDs across multiple levels of
> directories underneath /mnt/disk?/mythtv/videos/. As I said these are
> SSDs (SATA-connected), so quite fast. The backend's CPU is a 4GHz Intel
> i3-8350K, and the box also has plenty of RAM (32GB).
>
> Should I report this as a bug?
>
> Many thanks, Jan
> _______________________________________________

Thanks for testing this. I have about 1500 videos (on hard drive) and it 
takes between 1 and 2 seconds. With 5500 videos I would expect no more 
than 7 seconds.

I can investigate using a lazy load for videos. That may conflict with 
the directory listing scheme I have, where directories are listed and 
you can drill down.

Do you use directories?

When it takes a long time, how many rows are reported (at the top level 
each direcory is a row)?

Does clicking on a directory to see its contents also take a long time?

Does clicking back on Videos at the top after looking at a subdirectory 
also take a long time?

Peter


More information about the mythtv-users mailing list