[mythtv-users] Mythweb, --noupnp and the status page

James Klaas jklaas at appalachian.dyndns.org
Fri Sep 25 12:48:52 UTC 2020

> On Thu, 24 Sep 2020 08:32:22 -0400, you wrote:
>>I recently upgraded mythtv on my Buster server to 30.0 from
>> deb-multimedia.
>>After I got everything sorted out and working to my satisfaction, I
>>discovered that the status page for my mythweb install would produce a
>>404 error. After some searching around I found someone who mentioned
>>removing the "--noupnp" option from mythtvbackend flags was the
>>However, I don't really want my mythbackend to be running a upnp
>>server as I rely on other programs for that service.
>>Is this a mythtv bug or a packaging bug somehow?
>>I didn't see any issues in trac to indicate anyone reported this.
> Removing -noupnp should only fix it if it was a firewall problem where
> port 6544 was blocked.  Do you have a firewall running on your Buster
> server?

I do have a firewall.

> Are there any firewalls between the box where you are
> accessing mythweb and the Buster server?

I'm accessing from a remote host. I also tried from a browser on the
localhost and got the same result.

> In your case, is the 404 error from getting pages from mythweb, or do
> you get a mythweb page with a 404 error displayed inside it where the
> status fetch from port 6544 failed?

It's the Mythweb page decorations, with a "404 Not Found." under the banner.

> Do other mythweb pages load
> properly?

As far as I can tell, all the other mythweb pages load fine.

> Does this URL work:
> http://yourBackendHostNameOrIP:6544/Status/GetStatusHTML

I get a 404 page not found error with --noupnp enabled.

I disabled the firewall and I still get a 404 error when "--noupnp" is enabled.

More information about the mythtv-users mailing list