[mythtv-users] Segfault on starting playback

Jim Stichnoth stichnot at gmail.com
Tue Sep 4 14:20:06 UTC 2012

On Tue, Sep 4, 2012 at 2:47 AM, Stephen Robertson
<stephengrobertson at gmail.com> wrote:
> Well I'm making progress,sort of, but no explanation yet!
> Built the latest from git, installed and run.  Tried my "broken"
> recording and it played every time.  Then I realised I had not applied
> your patch!
> Uninstalled, installed from mythbuntu ppa, tried the same recording
> and, as expected, on the second attempt I get a segmentation fault.
> Removed the mythbunutu version, installed my local build (still
> without the patch) and the recording plays back fine.

At this point, it's pretty clear that uninitialized fields in a
stack-allocated struct are causing the problem.  Possibly the
mythbuntu builds are using a compiler version and/or options that lead
to "bad" values of the uninitialized fields, whereas your compiler and
mine happen to be OK most of the time.

In any case, we just have to work out the cleanest fix in the upstream
ffmpeg code that we incorporate, which should be very soon.


More information about the mythtv-users mailing list