[mythtv-users] error loading shared library libmythzmq.so.1

Gavin Hurlbut gjhurlbu at gmail.com
Mon Jul 2 19:45:37 UTC 2012

On Mon, Jul 2, 2012 at 12:23 PM, John Nissley <jnissley at nissley.org> wrote:
> On 07/01/2012 05:37 PM, John Nissley wrote:
>> I just downloaded the latest mythtv trunk today and tried to compile and
>> run it.  I was able to compile without a problem but when I tried to run
>> mythbackend I get the following error:
>> mythbackend: error while loading shared libraries: libmythzmq.so.1:
>> cannot open shared object file: No such file or directory
> You did not get a Makefile-type error on zeromq? My attempts to compile
> trunk (from yesterday afternoon) all failed with a 'no rule for install'
> type error. There is no Makefile in the folder (nor in nzmt or qjson). I
> presume the Makefile in the parent is supposed to be sufficient but NOT.

It most certainly is.

What you need to do is to run ./configure at the top level of MythTV
first, then make from the top level of MythTV.  This chains down to
the external libraries correctly, including running their individual
configure scripts where needed.  Any other method of building this is

You likely want to make distclean first from the top level too.

>> I looked at the recent commits and I assume it has something to do with
>> the commit that moved external libs under a new directory.  I tried to
>> undo what was done on that commit but it did not seem to make any
>> difference.
> Hhhmm, methinks I now need to know how to pull a prior revision level
> using git. I knew how to do that with subversion. Meh, schoolwork on a
> holiday!

This makes no sense.  It builds as designed.  You are doing it wrong :)

> I got the error for zeromq and now forget how I resolved it.  I think I
> went to where ever there was a Makefile and did a make distclean or ran
> a make from that specific Makefile location and tried to resolve what
> ever error it gave me.  Sorry i can not be more specific but that was
> in the middle of me trying to figure out the libmythzmq.so.q error.

When running master...  if things don't build as expected, go to the
top level of MythTV, and make uninstall, make distclean, and start
again.  Also, after distclean, manually delete any remaining installed
libraries or includes (if we moved the paths, as we did in this case).
 I don't know how you guys managed to get wedged :)

More information about the mythtv-users mailing list