[mythtv-users] error loading shared library libmythzmq.so.1

John Nissley jnissley at nissley.org
Mon Jul 2 19:23:31 UTC 2012

On 07/01/2012 05:37 PM, John Nissley wrote:
>/  I just downloaded the latest mythtv trunk today and tried to compile and
/>/  run it.  I was able to compile without a problem but when I tried to run
/>/  mythbackend I get the following error:
/>/  mythbackend: error while loading shared libraries: libmythzmq.so.1:
/>/  cannot open shared object file: No such file or directory
You did not get a Makefile-type error on zeromq? My attempts to compile
trunk (from yesterday afternoon) all failed with a 'no rule for install'
type error. There is no Makefile in the folder (nor in nzmt or qjson). I
presume the Makefile in the parent is supposed to be sufficient but NOT.

>/  I looked at the recent commits and I assume it has something to do with
/>/  the commit that moved external libs under a new directory.  I tried to
/>/  undo what was done on that commit but it did not seem to make any
/>/  difference.
Hhhmm, methinks I now need to know how to pull a prior revision level
using git. I knew how to do that with subversion. Meh, schoolwork on a


I got the error for zeromq and now forget how I resolved it.  I think I
went to where ever there was a Makefile and did a make distclean or ran
a make from that specific Makefile location and tried to resolve what
ever error it gave me.  Sorry i can not be more specific but that was
in the middle of me trying to figure out the libmythzmq.so.q error.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20120702/47da9bd6/attachment.html>

More information about the mythtv-users mailing list