[mythtv-users] error loading shared library libmythzmq.so.1

R. G. Newbury newbury at mandamus.org
Mon Jul 2 14:36:47 UTC 2012

On 07/01/2012 05:37 PM, John Nissley wrote:
> I just downloaded the latest mythtv trunk today and tried to compile and
> run it.  I was able to compile without a problem but when I tried to run
> mythbackend I get the following error:
> mythbackend: error while loading shared libraries: libmythzmq.so.1:
> cannot open shared object file: No such file or directory

You did not get a Makefile-type error on zeromq? My attempts to compile 
trunk (from yesterday afternoon) all failed with a 'no rule for install' 
type error. There is no Makefile in the folder (nor in nzmt or qjson). I 
presume the Makefile in the parent is supposed to be sufficient but NOT.

> I looked at the recent commits and I assume it has something to do with
> the commit that moved external libs under a new directory.  I tried to
> undo what was done on that commit but it did not seem to make any
> difference.

Hhhmm, methinks I now need to know how to pull a prior revision level 
using git. I knew how to do that with subversion. Meh, schoolwork on a 


More information about the mythtv-users mailing list