[mythtv-users] error loading shared library libmythzmq.so.1

Nicolas Riendeau knight at teksavvy.com
Sun Jul 1 22:01:38 UTC 2012


On 7/1/2012 5:37 PM, John Nissley wrote:
> I just downloaded the latest mythtv trunk today and tried to compile and
> run it.  I was able to compile without a problem but when I tried to run
> mythbackend I get the following error:
> mythbackend: error while loading shared libraries: libmythzmq.so.1:
> cannot open shared object file: No such file or directory

You wouldn't happen to have a 64 bit distribution by any chance?

That library gets sent to the regular lib directory instead of lib64 but 
I don't know if it's on purpose or not.

(I'll ping the dev involved to see if anything can be done about it...)

e.g. On my backend all the other libraries are sent to /usr/local/lib64 
while this one gets sent to /usr/local/lib .

As for fixing it Doug's suggestion should work (though with some 
distributions it might be preferable to add the new directory to a .conf 
file in /etc/ld.so.conf.d).

Have a nice day!


More information about the mythtv-users mailing list