[mythtv-users] error loading shared library libmythzmq.so.1

John Nissley jnissley at nissley.org
Sun Jul 1 23:35:48 UTC 2012


On 7/1/2012 5:37 PM, John Nissley wrote:
>/  I just downloaded the latest mythtv trunk today and tried to compile and
/>/  run it.  I was able to compile without a problem but when I tried to run
/>/  mythbackend I get the following error:
/>/  mythbackend: error while loading shared libraries: libmythzmq.so.1:
/>/  cannot open shared object file: No such file or directory
/
You wouldn't happen to have a 64 bit distribution by any chance?

That library gets sent to the regular lib directory instead of lib64 but
I don't know if it's on purpose or not.

(I'll ping the dev involved to see if anything can be done about it...)

e.g. On my backend all the other libraries are sent to /usr/local/lib64
while this one gets sent to /usr/local/lib .

As for fixing it Doug's suggestion should work (though with some
distributions it might be preferable to add the new directory to a .conf
file in /etc/ld.so.conf.d).

-----------------------------------------------------------------------
I should have asked the list earlier it would have saved me hours of
trial and error.

I am running a 64 bit version of Linux and already have /usr/local/lib64
in a file called mythtv.conf in the /etc/ld.so/conf.d directory I added
/usr/local/lib to my mythtv.conf file and now the backend will run.

My next question is if this will cause any problems going forward and
should I remove the /usr/local/lib from my configuration file in the
future?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.mythtv.org/pipermail/mythtv-users/attachments/20120701/d156b845/attachment.html>


More information about the mythtv-users mailing list