[mythtv-users] Firewire recording works in LiveTV but scheduled recordings unreliable

Michael T. Dean mtdean at thirdcontact.com
Tue Sep 27 02:54:46 UTC 2011


On 09/23/2011 04:42 AM, Les Noland wrote:
> OK -- it took a little doing but I finally got there.  I deleted my local
> definition of the "Default" storage group on my slave backend so that it
> would go back to using the one on the master, but every time I tried to run
> a test, it would record fine because it kept picking a local directory.  I
> finally had to go back and temporarily delete from the master's Default
> storage group any local directories so that all directories were remote.
> Then when I ran the test, it failed as before.
>
> I have attached the backend log and the output from the storagegroup query.
> A lot of the initial error messages in the log are due to the fact that I
> removed directories from the storage group so now it can't find some of the
> previously recorded shows, but the error demonstrating the problem is at the
> end of the file where it tried to record the movie "Marnie" but failed.

It looks like the recorder is querying for information before the 
recording is set up.

2011-09-13 07:17:29.539 QueryBasename found no entry for 6414 @ 2011-09-13T07:17:00
2011-09-13 07:17:29.552 QueryBasename found no entry for 6414 @ 2011-09-13T07:17:00
2011-09-13 07:17:29.620 RecordingInfo(6414_20110913071700.mpg): StartedRecording: Recording to '/6414_20110913071700.mpg'
2011-09-13 07:17:29.658 TVRec(10): Changing from None to RecordingOnly
2011-09-13 07:17:29.679 TVRec(10): HW Tuner: 10->10
2011-09-13 07:17:29.715 Launching: /usr/local/bin/sa3250ch -s -t 1 414
2011-09-13 07:17:29.727 PID 21822: launched
2011-09-13 07:17:30.891 PID 21822: exited: status=0, result=0
2011-09-13 07:17:30.959 (old)Settings::ReadSettings(settings.txt) - No such file
2011-09-13 07:17:31.008 LFireDev(001692D3FE120000): Buffered packets 2000 (8000 KB)
2011-09-13 07:17:31.459 TVRec(10): rec->GetPathname(): '/6414_20110913071700.mpg'
2011-09-13 07:17:31.477 TFW, Error: Opening file '/6414_20110913071700.mpg'.
			eno: Permission denied (13)
2011-09-13 07:17:31.493 TVRec(10) Error: RingBuffer '/6414_20110913071700.mpg' not open...
2011-09-13 07:17:31.514 TVRec(10): Changing from RecordingOnly to None
2011-09-13 07:17:31.534 Finished recording Marnie: channel 6414
2011-09-13 07:17:31.575 scheduler: Finished recording: Marnie: channel 6414


Not sure what would cause that, but the problem is before the storage 
groups/file stuff.  Can you run it, again, with -v schedule, please.

Mike


More information about the mythtv-users mailing list