[mythtv-users] dct-channel STB via Serial not working openSUSE 12.1

terry chusty at attglobal.net
Mon Nov 28 19:36:37 UTC 2011

opnseuse 12.1  3.1.0-1.2-desktop
mythtv 0.24 dct-channel v 1.7
Motorola cable box

Problem: the channel change script to use the serial port connected to
the STB does not work. /dev/tty5 is present,
permissions are OK, when call it to change channels hangs before DCT. 

$ channel -p /dev/ttyS5 -vv 12 
cursor moves to the next line and produce no errors and stays there.

If I 
$ channel 
Communication failed after 5 tries
Which show channel is working but /dev/ttyS0 (default) is not connected
which is correct. 

Description. I have a machine with dual boot, having opensuse 11.4 and
opensuse 12.1 in two different HD. Everything works Ok 
under opensuse 11.4 which ruled out BIOS setup as a problem.
 I did 2 clean installation in 12.1 with the same results. 

The pci serial card is recognized

# dmesg | grep Oxford
[    1.726854] 2 ports detected on Oxford PCI Express device

- ttyS5 is present in both

- setserial gives the same result in both

:~> setserial /dev/ttyS5
/dev/ttyS5, UART: 16950/954, Port: 0x0000, IRQ: 18

- the udev info is almost the same in both 

#udevadm info -a -p $(udevadm info -q path -n /dev/ttyS5)
every line in both OS is the same with one exception that the following
is present only in 11.4 
but i do not think makes any difference ?

 # dmesg | grep serial
[    1.569725] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.720562] serial 0000:04:00.0: PCI INT A -> GSI 18 (level, low) ->
IRQ 18
[    1.752498] serial 0000:07:01.0: PCI INT A -> GSI 19 (level, low) ->
IRQ 19

same in both OS versions

# dmesg | grep tty
[    0.000000] console [tty0] enabled
[    1.569725] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.711140] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.720714] ttyS4: detected caps 00000700 should be 00000500
[    1.720718] 0000:04:00.0: ttyS4 at MMIO 0xfb601000 (irq = 18) is a
[    1.736566] ttyS5: detected caps 00000700 should be 00000500
[    1.736579] 0000:04:00.0: ttyS5 at MMIO 0xfb601200 (irq = 18) is a
[    1.773294] 0000:07:01.0: ttyS6 at I/O 0xd080 (irq = 19) is a 16550A

In summary the serial port is recognized and udev produces the device.
It could be that other device is being used by the serial but I have
tried the other ttsS# with no good results.
 Any tips?
 Am I not loading a module required for this task?



More information about the mythtv-users mailing list