[mythtv-users] Is MythTV slowing down my SSH?

Michael T. Dean mtdean at thirdcontact.com
Sat Jan 22 05:04:15 UTC 2011

  On 01/21/2011 11:26 PM, Dave M G wrote:
> I have a Mythbuntu (10.10) that I often connect to by SSH in order to
> run various programs, such as Amarok. My Mythbuntu machine is where I
> store all my media, and it does some other file server duties and other
> things.
> In recent weeks, I've noticed a very significant slowdown in terms of
> response time when using an application over SSH. I have tried various
> fixes to SSH configuration files, but they have not helped.
> And then I came across this forum post:
> http://ubuntuforums.org/showthread.php?t=1614036
> In it, the poster describes an SSH problem very similar to mine. He then
> goes on to say that he solved the problem by fixing a corrupt MythTV
> database.
> I looked for how to check if a MythTV database is corrupt, I came across
> this page about character set corruption:
> http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding

That was about fixing a very specific data corruption.  It's not 
relevant to anyone on MythTV 0.22 and higher.

> However, I wondered if it was possible that my database could be
> corrupted in some other way. I looked around the net, and this is where
> it became more vague as to what might be wrong and how to fix it.
> Questions:
> Has anyone ever heard of MythTV/MySQL adversely affecting SSH before?

Not I.

> How likely is this to be the cause, and if it is, is there a way I can
> make get SSH to be unaffected?
> Are there any other likely tests I can do to see if somehow the MySQL
> has been corrupted?
> If it is true that I do have a corrupt database, and it is affecting
> SSH, I would be willing to just blow away my current database and start
> from scratch. I don't actually have any data in there at the moment that
> I care about. Is there a simple way to do that?
> Thank you for any advice.

I think the other poster may have been following a false lead.  It's 
/far/ more likely that socket issues (or other direct network issues) 
with MythTV would have affected SSH performance than for the data 
(schema + data) inside an application (MySQL Server) to have caused SSH 
slowdown.  Alternatively, it may have been a problem with MySQL 
networking causing issues with SSH network performance.

That said, I "wasn't there," so I don't know for sure what was going on 
(or what's happening for you).

Note, though, that if your sshd_config has UseDNS enabled (now the 
default in OpenSSH), and you have a configuration where the configured 
DNS server on your ssh server host cannot do a reverse IP address lookup 
on the connecting IP of the ssh client host, you will get a timeout for 
each "server" entry in your ssh server's resolv.conf (which is typically 
5s per entry) upon each connect.  This will also result in the ssh 
server's log files containing messages:

sshd[26714]: reverse mapping checking getaddrinfo for mythostname 
[xx.xx.xx.xx] failed - POSSIBLE BREAK-IN ATTEMPT!

And, TTBOMK, the only benefit of UseDNS is that it can show you these 
messages for any connecting host that doesn't have a valid 
reverse-IP-lookupable DNS entry.  I saw this with some Internet hosts I 
use because my ISP's DNS is configured to refuse to return reverse 
lookup information for its dynamic IP addresses.

Note that this wouldn't cause slowness in SSH once connected, but it can 
make connecting /very/ slow.


More information about the mythtv-users mailing list