[mythtv-users] using antec veris rm200 with kernel 2.6.37, lirc gives configuration problems on opensuse11.4 x86_64

Rob Verduijn rob.verduijn at gmail.com
Fri Apr 8 14:18:36 UTC 2011


Comment are below  :)

2011/4/8 Jarod Wilson <jarod at wilsonet.com>:
> On Apr 5, 2011, at 7:55 AM, Rob Verduijn wrote:
>> Hello all,
>> I've recently upgraded my opensuse frontend to a 64 bit installation
>> of opensuse 11.4.
>> This solved all kinds of problems for me that were biting me but has
>> returned one that is starting to frustrate me.
>> I cannot seem to get the lirc configuration working properly for the
>> antec veris with the remote rm200.
>> The vendor product id according to lsusb is : 15c2:0038 SoundGraph Inc.
>> And the remote is a : rm200
>> As some of you might know the kernel developers have absorbed the lirc
>> drivers into the kernel with the release of 2.6.35.
>> Opensuse 11.4 comes standard with the 2.6.37 kernel.
>> Most infrared devices we're still backwards compatible through the
>> /dev/lircd device. However this is not the case for the antec veris
>> remote.
>> You now have to configure this device using /dev/input/eventX.
> Or better yet, use the /dev/input/by-id/imon-whatever-if00 symlink,
> as that won't change on you like the X can in /dev/input/eventX. :)

I'll take a look at that.

>> I've been playing with this for some time now and got only partial
>> succes, on the remote some buttons work fine and some do not work at
>> all.
> What works and what doesn't? Try looking at the key data using either
> evtest or ir-keytable -t from v4l-utils.

I cannot check right now, but I've already made some progress.

In the suse repositories there is no v4l-utils package, and I've tried
to compile it from scratch but the compilation keeps failing.
I've also tried to check the buttons with the irw tool, but for some
reason mythtv reacts when I press a button but irw shows no output for
any key, not even for the ones that work.

After 3 days searching  the web I saw a mention about the "toggle
button" in some obscure forum I had a "DOH!!!!" moment.
Lirc starts the damn remote in the wrong mode.
I've had this setup in my old lircrc that ensured the right mode at
startup...completely forgot about it because I made that one like
almost 2 years ago.

Anyway mythtv is responding now and I can more or less use my remote.
I'm not satisfied by the keymapping though.

I need to get either irw to work or the v4l-utils to compile so that I
can set the keys the way I like them.

>> I've been testing the remote with irw and I only get output whit some
>> of the keys of the remote.
>> Does anybody have a working setup for opensuse 11.4 with this hardware
>> (15c2:0038 SoundGraph Inc.) ?
>> I'm especially interested in what is required in /etc/sysconfig/lirc
>> and /etc/lirc/lircd.conf.
>> Currently I've used the
>> /usr/share/lirc/remotes/devinput/lircd.conf.devinput file from the
>> lirc-remote rpm package as /etc/lirc/lircd.conf.
> That's the right one.

There are still some buttons missing in that config like the "GO" button.

>> This is what I've got in /etc/sysconfig/lirc
>> LIRCD_DEV_OWNER="root:video"
>> LIRCD_DRIVER="devinput"
>> LIRCD_DEVICE="/dev/input/event4"
> Looks fine to me, unless 4 is moving on you. Note also that, iirc, the
> remote will start in mouse mode in 2.6.37, rather than keyboard mode.
> Keyboard mode is the default in 2.6.38 and on though. But you may find

2.6.38 is not working with the curent or beta nvidia drivers and I
kinda need that for my frontend since I cannot convince the misses to
watch ascii art tv.

> that more keys start working after you hit the mouse/keyboard toggle...

See previous DOH statement

> --
> Jarod Wilson
> jarod at wilsonet.com
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://www.mythtv.org/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list