[mythtv-users] using antec veris rm200 with kernel 2.6.37, lirc gives configuration problems on opensuse11.4 x86_64

Jarod Wilson jarod at wilsonet.com
Fri Apr 8 14:54:18 UTC 2011


On Apr 8, 2011, at 10:18 AM, Rob Verduijn wrote:

> Hello,
> 
> Comment are below  :)
> 
> 2011/4/8 Jarod Wilson <jarod at wilsonet.com>:
>> On Apr 5, 2011, at 7:55 AM, Rob Verduijn wrote:
>> 
...
>>> I've been playing with this for some time now and got only partial
>>> succes, on the remote some buttons work fine and some do not work at
>>> all.
>> 
>> What works and what doesn't? Try looking at the key data using either
>> evtest or ir-keytable -t from v4l-utils.
> 
> I cannot check right now, but I've already made some progress.
> 
> In the suse repositories there is no v4l-utils package, and I've tried
> to compile it from scratch but the compilation keeps failing.
> I've also tried to check the buttons with the irw tool, but for some
> reason mythtv reacts when I press a button but irw shows no output for
> any key, not even for the ones that work.

That suggests lircd isn't connecting to the correct input event
device.


> After 3 days searching  the web I saw a mention about the "toggle
> button" in some obscure forum I had a "DOH!!!!" moment.
> Lirc starts the damn remote in the wrong mode.

lirc has nothing to do with it. Its the kernel-level device driver.


> I've had this setup in my old lircrc that ensured the right mode at
> startup...completely forgot about it because I made that one like
> almost 2 years ago.

Um. There's no way to toggle the mode via an lircrc. Two years ago,
I believe mouse mode support simply didn't exist.


> Anyway mythtv is responding now and I can more or less use my remote.
> I'm not satisfied by the keymapping though.
> 
> I need to get either irw to work or the v4l-utils to compile so that I
> can set the keys the way I like them.

You shouldn't need to do anything but get lircd configured correctly
and then you can just map things in ~/.lircrc.


>>> I've been testing the remote with irw and I only get output whit some
>>> of the keys of the remote.
>>> 
>>> Does anybody have a working setup for opensuse 11.4 with this hardware
>>> (15c2:0038 SoundGraph Inc.) ?
>>> I'm especially interested in what is required in /etc/sysconfig/lirc
>>> and /etc/lirc/lircd.conf.
>>> 
>>> Currently I've used the
>>> /usr/share/lirc/remotes/devinput/lircd.conf.devinput file from the
>>> lirc-remote rpm package as /etc/lirc/lircd.conf.
>> 
>> That's the right one.
> 
> There are still some buttons missing in that config like the "GO" button.

No, there isn't.

Kernel side keymap:

        { 0x2ab195b7, KEY_MEDIA }, /* Go or MultiMon */

The scancode for the Go button is mapped to the linux input layer
key KEY_MEDIA (actually, in 2.6.37, I think its KEY_PROG1), and
that's what lircd.conf.devinput matches against.


-- 
Jarod Wilson
jarod at wilsonet.com





More information about the mythtv-users mailing list