[mythtv-users] Can't get RTSP source working in 0.21 or 0.23

Christian Hack christian at hack.id.au
Mon Apr 4 04:25:08 UTC 2011

I've been trying for a few days to get some channels fed via RTSP into MythTV. They are coming from TVHeadend which is decrypting my
local cable TV provider using my subscriber card. TVHeadend is working much much more reliably than sasc-ng ever has.


So I have a bunch of RTSP sources like this (all running on the same machine as the backend) all running on the local LAN and even
on the same machine eventually. So no firewalls or port forwarding type issues most likely.






.for each cable TV channel.


I also have equivalent HTTP streams at


Which work well too. Both play fine with vlc and mplayer on multiple machines (Windows desktop, Mythtv backend and frontends). HTTP
works better though it seems. I've also tried some external RTSP feeds from the internet which likewise work fine (aside from
bandwith issues) in mplayer and vlc but not in MythTV


My main system is 0.21 (Mythdora 10) but I have also tried with basically the same results in a VM running a fresh Mythdora 12.23
(Myth 0.23) installation


I have playlist.m3u on the same local machine looking like this:



#EXTINF:0,501 - Fox Sports 1


#EXTINF:0,502 - Fox Sports 2


#EXTINF:0,503 - Fox Sports 3



Channels are all set up properly as far as I can tell with a FREEBOX/Network Recorder and MythTV starts up and starts initiating the
connection. Basically as per this (which seems to have been deleted just recently):



Using tcpdump I can see the RTSP server sending lots of UDP packets towards the client. However they never get into MythTV and I
never see a picture or sound. When I start LiveTV I get a lock status of "L__" only and nothing more.


I found a note about hostname not properly resolving to the correct IP of the machine (only the loopback address) with the live555
code and that's fixed (only had to fix the new VM)


http://forum.videolan.org/viewtopic.php?f=13 <http://forum.videolan.org/viewtopic.php?f=13&t=41334> &t=41334


I have tried use vlc as an intermediate server to supply via udp and that didn't work either:



I seem to be having this same sort of problem as Per, later in this thread:



Aside from that I'm not sure what else to actually try. Any ideas? Other applications work fine on the same machine suggesting not
network, OS or machine issues. It's just MythTV that won't work.


Any ideas?




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-users/attachments/20110404/2fbf8541/attachment.html 

More information about the mythtv-users mailing list