[mythtv-users] HD-PVR IR Blaster

Jarod Wilson jarod at wilsonet.com
Thu May 20 19:39:11 UTC 2010

On Thu, May 20, 2010 at 11:46 AM, Michael Knoll <michael.knoll at gmail.com> wrote:
> I am stuck trying to get the IR Blaster on the HD-PVR working.  I was
> hoping someone could help.
> I am running Ubuntu 10.04.  The machine previously had an MCE Remote,
> but there was no blaster.  I followed the directions on the wiki at
> http://www.mythtv.org/wiki/HD-PVR.  I used the lircd.conf from
> http://www.blushingpenguin.com/mark/lmilk/lircd.conf.  I copied the
> firmware.  I also needed to do a "depmod", since the lirc_zilog.ko
> module was added, not replace.  I'd add it to the wiki, but I'm not
> certain I am correct since it still doesn't work.  The modules load,
> but every time I try to send IR, I get:
> $irsend SEND_ONCE blaster 0_1_KEY_0
> irsend: command failed: SEND_ONCE blaster 0_1_KEY_0
> irsend: unknown remote: "blaster"
> The lircd.conf has a remote named blaster.  I've tried removing
> everything in the lircd.conf but the blaster remote and one button,
> but it still did not work.  This made me think it was not an error in
> the lircd.conf.  I tried setting the conf attribute in hardware.conf
> to the full path to my lircd.conf, thinking it wasn't finding the
> file, but I still got the same error.  I tried adding the -L and -D
> options to lircd's args, but it does not appear Ubuntu's lircd is
> compiled with support for them
> Can anyone offer any ideas?
> I have included a few command outputs and files that might be relevant.
> $ lsmod |grep lirc
> lirc_zilog             15651  3
> lirc_dev               12832  1 lirc_zilog
> $ dmesg |grep lirc
> [  234.267482] lirc_dev: IR Remote Control driver registered, major 250
> [  234.445062] lirc_zilog: Zilog/Hauppauge IR driver initializing
> [  234.455942] lirc_zilog: chip found with RX and TX
> [  234.458513] lirc_dev: lirc_register_driver: sample_rate: 0
> [  235.547832] lirc_zilog: Zilog/Hauppauge IR blaster firmware version
> 2.1.0 loaded
> [  235.547870] lirc_zilog: initialization complete
> $ ls -l /dev/lirc*
> crw-rw---- 1 root root 250, 0 2010-05-19 23:43 /dev/lirc0
> lrwxrwxrwx 1 root root     19 2010-05-20 11:16 /dev/lircd -> /var/run/lirc/lircd
> lrwxrwxrwx 1 root root     20 2010-05-20 11:16 /dev/lircd1 ->
> /var/run/lirc/lircd1
> $ cat /etc/lirc/hardware.conf

I would like to take that file out back and put it out of my misery.
Its almost *always* being populated incorrectly (not by you, but by
the package setup thingy)...

> # /etc/lirc/hardware.conf
> #
> #Chosen Remote Control
> REMOTE="Windows Media Center Transceivers/Remotes (all)"
> REMOTE_MODULES="lirc_dev lirc_zilog"
> REMOTE_DEVICE="/dev/lirc0"

You have no lircd.conf specified here, though /etc/lirc/lircd.conf
should be used by default. Run 'irsend LIST "" ""' (yes, two sets of
quotes w/nothing in between), and lircd will tell you what remote
names it actually knows about. From your earlier output, lircd knows
nothing about the remote "blaster", so until you get that part sorted,
nothing is going to work.

> #Chosen IR Transmitter
> TRANSMITTER_MODULES="lirc_dev lirc_zilog"

This is the part that should be slaughtered. When there is only a
single device, there should only be one setup stanza. You've got two
lircd instances running for no reason at all, both binding to the same
device here. (This is jokes and fail galore when people answer "yes, I
have a transmitter and a remote!" when they're using a single device
capable of both transmit and receive. It only makes sense if there are
multiple devices to have both stanzas filled in. A simple "are your
transmit and receive devices one in the same?" asked of the user would
probably eliminate this folly...)

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list