[mythtv-users] HD-PVR IR Blaster

Michael Knoll michael.knoll at gmail.com
Thu May 20 15:46:04 UTC 2010

I am stuck trying to get the IR Blaster on the HD-PVR working.  I was
hoping someone could help.

I am running Ubuntu 10.04.  The machine previously had an MCE Remote,
but there was no blaster.  I followed the directions on the wiki at
http://www.mythtv.org/wiki/HD-PVR.  I used the lircd.conf from
http://www.blushingpenguin.com/mark/lmilk/lircd.conf.  I copied the
firmware.  I also needed to do a "depmod", since the lirc_zilog.ko
module was added, not replace.  I'd add it to the wiki, but I'm not
certain I am correct since it still doesn't work.  The modules load,
but every time I try to send IR, I get:

$irsend SEND_ONCE blaster 0_1_KEY_0
irsend: command failed: SEND_ONCE blaster 0_1_KEY_0
irsend: unknown remote: "blaster"

The lircd.conf has a remote named blaster.  I've tried removing
everything in the lircd.conf but the blaster remote and one button,
but it still did not work.  This made me think it was not an error in
the lircd.conf.  I tried setting the conf attribute in hardware.conf
to the full path to my lircd.conf, thinking it wasn't finding the
file, but I still got the same error.  I tried adding the -L and -D
options to lircd's args, but it does not appear Ubuntu's lircd is
compiled with support for them

Can anyone offer any ideas?

I have included a few command outputs and files that might be relevant.

$ lsmod |grep lirc
lirc_zilog             15651  3
lirc_dev               12832  1 lirc_zilog

$ dmesg |grep lirc
[  234.267482] lirc_dev: IR Remote Control driver registered, major 250
[  234.445062] lirc_zilog: Zilog/Hauppauge IR driver initializing
[  234.455942] lirc_zilog: chip found with RX and TX
[  234.458513] lirc_dev: lirc_register_driver: sample_rate: 0
[  235.547832] lirc_zilog: Zilog/Hauppauge IR blaster firmware version
2.1.0 loaded
[  235.547870] lirc_zilog: initialization complete

$ ls -l /dev/lirc*
crw-rw---- 1 root root 250, 0 2010-05-19 23:43 /dev/lirc0
lrwxrwxrwx 1 root root     19 2010-05-20 11:16 /dev/lircd -> /var/run/lirc/lircd
lrwxrwxrwx 1 root root     20 2010-05-20 11:16 /dev/lircd1 ->

$ cat /etc/lirc/hardware.conf
# /etc/lirc/hardware.conf
#Chosen Remote Control
REMOTE="Windows Media Center Transceivers/Remotes (all)"
REMOTE_MODULES="lirc_dev lirc_zilog"

#Chosen IR Transmitter
TRANSMITTER_MODULES="lirc_dev lirc_zilog"

#Enable lircd

#Don't start lircmd even if there seems to be a good config file

#Try to load appropriate kernel modules

# Default configuration files for your hardware if any

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"

More information about the mythtv-users mailing list