[mythtv-users] HD-PVR /dev/lirc does not exist

Captain Krypto captainkrypto at gmail.com
Sun May 9 11:49:27 UTC 2010

> > Just a guess, but is the service started?
> >
> > "service lirc start"
> The device node /dev/lirc0 is created when the lirc kernel driver
> successfully loads, not when lircd is started.
> > I had the same problem on FC10 so I just added something like this to
> > /etc/rc.d/rc.local :
> >
> > if [ ! -e /dev/lirc0 ]; then
> > mknod /dev/lirc0 c 61 0
> > chown root:root /dev/lirc0
> > chmod 660 /dev/lirc0
> > fi
> >
> > Kinda hackey, but it worked.
> Um. No. It didn't. Trust me. The only thing it might possibly have
> done is make lirc happy because its got a device node to connect to
> before the driver is actually registered. Current lirc will actually
> happily start up and wait for the device node to appear. But a driver
> *must* get loaded and *must* register an lirc device for something to
> actually be backing /dev/lircX. Simply creating the device node does
> NOT accomplish that.
> > This post might help:
> >
> http://www.linuxquestions.org/questions/slackware-14/lirc-linux-remote-control-isnt-setting-up-dev-properly-udev-problem-599664/
> No, the real answer is this: the hdpvr ir enable patch was
> accidentally dropped from the Fedora kernels when they were rebased
> from 2.6.31 to 2.6.32, and I haven't got around to putting it back in
> place. In other words, its not going to work until he's got an hdpvr
> driver patched to enable the ir part.
> --
> Jarod Wilson
> jarod [at] wilsonet

Sheesh!  Did someone pee in your corn flakes this morning?

I never claimed to be an expert, nor to know the exact problem causing the
OPs issue.  I was simply stating what worked for *me* and offering
*possible* solutions.  Nothing was stated as fact and I'm sure people on
this list are smart enough to make that distinction.  Your sarcastic remarks
and down-talking were unnecessary and unwarranted.

I had perceived you as good guy helping out the community by, among other
things, creating the Fedora setup guides.  I had used your guides several
times to set up my own myth machines and can truly say that I appreciate
their existence, but I now realize that they were only created in a vain
attempt to demonstrate your "linux superiority".

I re-read your reply several times in the voice of The Comic Book Guy from
The Simpsons and it made me laugh.  So, thanks for that at least.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20100509/c8796d95/attachment.htm>

More information about the mythtv-users mailing list