[mythtv-users] HD-PVR /dev/lirc does not exist

Jarod Wilson jarod at wilsonet.com
Mon May 10 03:20:57 UTC 2010

On Sun, May 9, 2010 at 7:49 AM, Captain Krypto <captainkrypto at gmail.com> wrote:
>> > Just a guess, but is the service started?
>> >
>> > "service lirc start"
>> The device node /dev/lirc0 is created when the lirc kernel driver
>> successfully loads, not when lircd is started.
>> > I had the same problem on FC10 so I just added something like this to
>> > /etc/rc.d/rc.local :
>> >
>> > if [ ! -e /dev/lirc0 ]; then
>> > mknod /dev/lirc0 c 61 0
>> > chown root:root /dev/lirc0
>> > chmod 660 /dev/lirc0
>> > fi
>> >
>> > Kinda hackey, but it worked.
>> Um. No. It didn't. Trust me. The only thing it might possibly have
>> done is make lirc happy because its got a device node to connect to
>> before the driver is actually registered. Current lirc will actually
>> happily start up and wait for the device node to appear. But a driver
>> *must* get loaded and *must* register an lirc device for something to
>> actually be backing /dev/lircX. Simply creating the device node does
>> NOT accomplish that.
>> > This post might help:
>> >
>> > http://www.linuxquestions.org/questions/slackware-14/lirc-linux-remote-control-isnt-setting-up-dev-properly-udev-problem-599664/
>> No, the real answer is this: the hdpvr ir enable patch was
>> accidentally dropped from the Fedora kernels when they were rebased
>> from 2.6.31 to 2.6.32, and I haven't got around to putting it back in
>> place. In other words, its not going to work until he's got an hdpvr
>> driver patched to enable the ir part.
> Sheesh!  Did someone pee in your corn flakes this morning?
> I never claimed to be an expert, nor to know the exact problem causing the
> OPs issue.  I was simply stating what worked for *me* and offering
> *possible* solutions.  Nothing was stated as fact and I'm sure people on
> this list are smart enough to make that distinction.  Your sarcastic remarks
> and down-talking were unnecessary and unwarranted.
> I had perceived you as good guy helping out the community by, among other
> things, creating the Fedora setup guides.  I had used your guides several
> times to set up my own myth machines and can truly say that I appreciate
> their existence, but I now realize that they were only created in a vain
> attempt to demonstrate your "linux superiority".
> I re-read your reply several times in the voice of The Comic Book Guy from
> The Simpsons and it made me laugh.  So, thanks for that at least.

I apparently forgot to add strategically-placed smiley faces to my
reply. Wasn't intending to be sarcastic or talk down to anyone, I was
intending to provide a thorough accounting of what was actually going
on, and how lirc actually works (which a LOT of people get wrong), and
made some tongue-in-cheek comments you've taken the wrong way. Thank
you for trying to help. And I don't eat corn flakes.

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list