[mythtv-users] Connecting HD-PVR to USB3 mini-PCIe card doesn't work

Jarod Wilson jarod at wilsonet.com
Tue Dec 21 03:11:05 UTC 2010

On Dec 20, 2010, at 9:27 PM, Daniel Born wrote:

> Hello all,
> In an effort to minimize hd-pvr freezes, I decided to get
> an expansion card USB port to get the hd-pvr off the main
> usb controller on the main board (according to forums, this
> might help...)
> After installing a Vantec UGT-PC302 Mini-PCIe USB3 card and plugging the
> hd-pvr in, it doesn't seem to work.
> I get the following messages in kern.log:
> hdpvr 6-3:1.0: usb_submit_urb in hdpvr_submit_buffers
> returned -12
> xhci_hcd 0000:02:00.0: ERROR no room on ep ring
> hdpvr 6-3:1.0: couldn't submit buffers
> hdpvr 6-3:1.0: device /dev/video0 disconnected
> In mythbackend.log, I get this:
> DevRdB(/dev/video0) Error: Poll giving up
> MPEGRec(/dev/video0) Error: Device error detected
> DevRdB(/dev/video0): Stop(): Not running.
> MPEGRec(/dev/video0) Error: StopEncoding failed
> eno: Resource temporarily unavailable (11)
> MPEGRec(/dev/video0) Warning: Unable to set audio input.
> I'm wondering if it's early(?) support for USB3 that's at
> cause in Ubuntu 10.04 or if it's due to this particular
> card's support (or Mini-PCIe type card).

The Linux kernel's usb3 support is REALLY immature, I'd wager its a
problem with the xhci driver stack. I know its still not exactly
100% solid yet even in 2.6.37, and Ubuntu 10.04's kernel is a lot
older than that.

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list