[mythtv-users] Connecting HD-PVR to USB3 mini-PCIe card doesn't work

Daniel Born born_daniel at yahoo.com
Tue Dec 21 02:27:25 UTC 2010

Hello all,

In an effort to minimize hd-pvr freezes, I decided to get
an expansion card USB port to get the hd-pvr off the main
usb controller on the main board (according to forums, this
might help...)

After installing a Vantec UGT-PC302 Mini-PCIe USB3 card and plugging the
hd-pvr in, it doesn't seem to work.

I get the following messages in kern.log:
hdpvr 6-3:1.0: usb_submit_urb in hdpvr_submit_buffers
returned -12
xhci_hcd 0000:02:00.0: ERROR no room on ep ring
hdpvr 6-3:1.0: couldn't submit buffers
hdpvr 6-3:1.0: device /dev/video0 disconnected

In mythbackend.log, I get this:
DevRdB(/dev/video0) Error: Poll giving up
MPEGRec(/dev/video0) Error: Device error detected
DevRdB(/dev/video0): Stop(): Not running.
MPEGRec(/dev/video0) Error: StopEncoding failed
eno: Resource temporarily unavailable (11)
MPEGRec(/dev/video0) Warning: Unable to set audio input.

I'm wondering if it's early(?) support for USB3 that's at
cause in Ubuntu 10.04 or if it's due to this particular
card's support (or Mini-PCIe type card). When the hd-pvr is
plugged in the motherboard's USB2 ports, it works just fine (except for the more-or-less frequent freezes).

Any patch available for this or should I return the card
and get another make (or stick with USB2 since I don't
*really* need USB3 for this).

I know this is probably more a Linux than Mythtv problem but since
this concerns the HD-PVR, I'm hoping to get better luck


More information about the mythtv-users mailing list