[mythtv-users] Need Help: HD-PVR IRBlaster

Jarod Wilson jarod at wilsonet.com
Mon Dec 20 18:31:25 UTC 2010

On Dec 20, 2010, at 11:43 AM, Martin Lynch wrote:

> *Resent in plain text; changed subject to avoid confusion with Mark Pennock's thread*
> On 10-12-18 10:10 PM, martin.lynch.toronto at gmail.com wrote:
>> Following some good advice I received here, I've gone ahead and bought the Hauppauge HD-PVR. It works fine, except I cannot get the IRBlaster to work. It's been 2 weeks now of Googling and trying all manner of suggestions.
>> Two questions:
>> - can anyone who has the IRBlaster working with an HD-PVR possibly post lircd.conf and hardware.conf? Am running Ubuntu 10.04, if that's important.
>> - can anyone who is successfully changing channels on a Bell 9241 likewise post their channel changing script? I think (but am not certain) that this is equivalent to a Dish vip 612.
>> I have compiled lirc_zilog and lirc_dev and downloaded the HD-PVR driver, etc etc etc.
>> My IRBlaster plugs directly into the HD-PVR. I don't need the remote to work, just the channel changes.
>> "irsend" doesn't work (variety of error messages, which I'm happy to post if needed).
>> "irsend LIST "" """ returns nothing.
>> I've been using firewire very successfully for the past 4 years, however my Bell boxes do not include a firewire port (I'm in Canada so they are not legally required to).
>> Any and all help is very much appreciated, because I've been going in circles for days now on this.
>> Thanks!
> OK, some additional info:
> /var/run/lirc/ contains lircd and lircd.pid
> /dev/ contains lirc0 and lircd, which is a link to /var/run/lirc/lircd (which I think I created manually - I've tried so many variations to get this working that I'm no longer certain...).
> $ sudo irsend -d /dev/lircd SEND_ONCE blaster select
> irsend: command failed: SEND_ONCE blaster select
> irsend: hardware does not support sending
> $ sudo irsend -d /dev/lirc0 SEND_ONCE blaster select
> irsend: could not connect to socket
> irsend: Connection refused
> /var/run/lirc$ ls -al
> total 4
> drwxr-xr-x  2 root root  80 2010-12-18 17:48 .
> drwxr-xr-x 25 root root 860 2010-12-19 07:42 ..
> srw-rw-rw-  1 root root   0 2010-12-18 17:48 lircd
> -rw-r--r--  1 root root   5 2010-12-18 17:48 lircd.pid
> $ uname -a
> Linux HTPC 2.6.31-11-rt #154-Ubuntu SMP PREEMPT RT Wed Jun 9 13:40:34 UTC 2010 x86_64 GNU/Linux

Do you have a patched hdpvr driver that enables the IR part? That's
a requirement for lirc_zilog to be able to bind to the hardware. You
mention you "downloaded the HD-PVR driver", but I don't know exactly
what that means. What sort of output do you see in dmesg just after
driver load? (even better, after 'modprobe lirc_zilog debug=1'). You
appear to have *something* creating /dev/lirc0, but it doesn't seem
to be lirc_zilog.

> PS: when making changes to lircd.conf or hardware.conf (or changes to /dev/lirc) is it a requirement to restart lircd for the changes to take effect?

Yes, yes, and maybe (depends on the changes).

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list