[mythtv-users] Need Help: HD-PVR IRBlaster

Martin Lynch martin.lynch.toronto at gmail.com
Mon Dec 20 16:43:43 UTC 2010

*Resent in plain text; changed subject to avoid confusion with Mark 
Pennock's thread*

On 10-12-18 10:10 PM, martin.lynch.toronto at gmail.com wrote:
> Following some good advice I received here, I've gone ahead and bought the Hauppauge HD-PVR. It works fine, except I cannot get the IRBlaster to work. It's been 2 weeks now of Googling and trying all manner of suggestions.
> Two questions:
> - can anyone who has the IRBlaster working with an HD-PVR possibly post lircd.conf and hardware.conf? Am running Ubuntu 10.04, if that's important.
> - can anyone who is successfully changing channels on a Bell 9241 likewise post their channel changing script? I think (but am not certain) that this is equivalent to a Dish vip 612.
> I have compiled lirc_zilog and lirc_dev and downloaded the HD-PVR driver, etc etc etc.
> My IRBlaster plugs directly into the HD-PVR. I don't need the remote to work, just the channel changes.
> "irsend" doesn't work (variety of error messages, which I'm happy to post if needed).
> "irsend LIST "" """ returns nothing.
> I've been using firewire very successfully for the past 4 years, however my Bell boxes do not include a firewire port (I'm in Canada so they are not legally required to).
> Any and all help is very much appreciated, because I've been going in circles for days now on this.
> Thanks!
> Sent from my BlackBerry device on the Rogers Wireless Network

OK, some additional info:

/var/run/lirc/ contains lircd and lircd.pid
/dev/ contains lirc0 and lircd, which is a link to /var/run/lirc/lircd 
(which I think I created manually - I've tried so many variations to get 
this working that I'm no longer certain...).


This file is 31,132 lines long, which I'm happy to post if needed. It 
begins with:


# this config file was automatically generated
# using lirc-0.5.5pre8 on Sun Apr 18 11:43:45 1999
# contributed by Jens Leuschner <leuschner at gmx.net>
# brand:             Hauppauge
# model:
# supported devices: WinTV primo; WinTV pci; WinTV radio
# This config file will work with both homebrew receivers and
# original Hauppauge TV cards !!!

begin remote

   name          blaster
   bits          32
   flags         RAW_CODES
   eps           0
   aeps          0
   plead         0
   gap           333333
   repeat_bit    0
   begin raw_codes
     name 0_1_KEY_0


/etc/lirc/hardware.conf (please note I've commented out the REMOTE 
stanza as part of my testing; have also tried commenting out the 
TRANSMITTER stanza and uncommenting the REMOTE stanza, and also 
uncommenting both):


# /etc/lirc/hardware.conf

#Chosen IR Transmitter
TRANSMITTER_MODULES="lirc_dev lirc_zilog"

#Chosen Remote Control
#REMOTE_MODULES="lirc_dev lirc_zilog"

#Enable lircd

#Don't start lircmd even if there seems to be a good config file

#Try to load appropriate kernel modules

# Default configuration files for your hardware if any

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"

# Remote settings required by gnome-lirc-properties


$sudo irsend LIST "" "" returns nothing.

$ sudo irsend -d /dev/lircd SEND_ONCE blaster select
irsend: command failed: SEND_ONCE blaster select
irsend: hardware does not support sending

$ sudo irsend -d /dev/lirc0 SEND_ONCE blaster select
irsend: could not connect to socket
irsend: Connection refused

/var/run/lirc$ ls -al
total 4
drwxr-xr-x  2 root root  80 2010-12-18 17:48 .
drwxr-xr-x 25 root root 860 2010-12-19 07:42 ..
srw-rw-rw-  1 root root   0 2010-12-18 17:48 lircd
-rw-r--r--  1 root root   5 2010-12-18 17:48 lircd.pid

$ uname -a
Linux HTPC 2.6.31-11-rt #154-Ubuntu SMP PREEMPT RT Wed Jun 9 13:40:34 
UTC 2010 x86_64 GNU/Linux

$ ls -al /lib/firmware/ | grep haup*
-rwxr-xr-x  1 martin martin  302355 2010-12-11 20:39 haup-ir-blaster.bin

The command line which started lircd is:

/usr/sbin/lircd --output=/var/run/lirc/lircd --device=/dev/lirc

If I create a symlink called /dev/lirc pointing at /var/run/lirc/lircd I 
get the following result:

$ sudo irsend -d /dev/lirc SEND_ONCE blaster select
irsend: command failed: SEND_ONCE blaster select
irsend: unknown remote: "blaster"

If I instead create a symlink called /dev/lirc pointing at 
/var/run/lirc/lircd.pid, I get

$ sudo irsend -d /dev/lirc SEND_ONCE blaster select
irsend: could not connect to socket
irsend: Connection refused

I think all the correct modules have been compiled and are loaded correctly:

$ lsmod | grep lirc
lirc_zilog             18972  0
lirc_dev               16744  1 lirc_zilog

If I turn on the STB and go into live TV in mythtv, I can watch TV just 
fine, provided I change channels using the STB remote. This, of course, 
won't work for scheduled recordings - my point is simply that the HD-PVR 
appears to work.

Could really use some help, as I'm leaving soon for a trip and would 
dearly like to have my scheduled shows record.

PS: when making changes to lircd.conf or hardware.conf (or changes to 
/dev/lirc) is it a requirement to restart lircd for the changes to take 

Many thanks!

More information about the mythtv-users mailing list