[mythtv-users] Serial IR Blaster Not Working Kernel

Jarod Wilson jarod at wilsonet.com
Tue Dec 14 21:04:13 UTC 2010

On Dec 13, 2010, at 3:56 PM, Paul Check wrote:

> Hi: I have a serial ir blaster (homebrew, from irblaster.info). Previously
> I had this working with 2.6.31 kernels via the debian lirc-modules-source
> package.  I upgraded to kernel from kernel.org and have tried to
> get the lirc modules in the (stagging area of the) kernel working.  I
> compiled for lirc_i2c and lirc_serial.  (Note: When I load lirc_serial,
> the lirc_dev no longer loads). I believe I have all module options ok
> (other than the active high/low, although I've tried both), but I am not
> getting any channel changes.
> Since it *is* working on the 2.6.31 kernel, something must be wrong with

Yep, seems that way. I need to dig out my serial tx thingy and make some
time to dig into it and figure out exactly what's wrong. Time is the big
one I'm having trouble coming up with of late, but I'm hoping that'll
change RSN...

> I notice that when I modprobe lirc_serial now, the major device
> number comes up as 254 instead of 61 under 2.6.31.

That's expected, and not a problem.

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list