[mythtv-users] HD-PVR driver issue. Please help!

sherslick at gmail.com sherslick at gmail.com
Mon Dec 13 16:56:21 UTC 2010


I tried the saa... Drivers simply because I was trying anything I could find online. 

I will post the results to the two commands as soon as I can, however I believe the fault lies in that when I do a make, then make install, then reboot that nothing changes. Modinfo hdpvr shows the same thing as a fresh install. 

(Fyi I tired doing make/make install at both /v4l-dvb and /v4l-dvb/v4l directories)
Sent from my Sprint BlackBerry®

-----Original Message-----
From: James Crow <crow.jamesm at gmail.com>
Sender: mythtv-users-bounces at mythtv.org
Date: Mon, 13 Dec 2010 11:43:15 
To: Discussion about MythTV<mythtv-users at mythtv.org>
Reply-To: Discussion about MythTV <mythtv-users at mythtv.org>
Subject: Re: [mythtv-users] HD-PVR driver issue. Please help!

On Sun, Dec 12, 2010 at 5:58 PM, Kris <sherslick at gmail.com> wrote:
> Dear list,
> I have been trying to a week to get Mythbuntu 10.10 to register my HD-PVR. I
> have figured out the issue is due to the driver not including my unit's USB
> ID. However after modifying the file and running make/install it still does
> not include the alias in modinfo.
> Here is what I have tried:
> modify/make/install driver from v4l-dvb from linuxtv.org
> modify/make/install driver from saa7164-stable from kernellabs
> Forgive me if I am missing something in the Linux driver process, but I am
> still fairly new to the Linux world. All I get in dmesg is "new full speed
> USB device using uhci_hcd and address 2"
> Please help I have read many guides and they all have you do roughly the
> same thing, but I cannot get the device to work. (I have installed the
> firmware on a win box, and did a record test with it)
> -Kris L

I am not sure why you want the saa7164 tree from kernel labs. The
saa7164 driver is for Hauppauge HVR-2250 (and HVR-2200) PCIe
ClearQAM/Analog MPEG2 recording cards. Just grab the main v4l-dvb
tree. If you have already grabbed the latest source and done a 'make',
'make install', and restart then you should have the newest driver.
There are ways to install and use the driver without a restart, but to
keep things simple I would recommend a restart.  On my Mythbuntu 10.04
system I can see the new driver file in the modules directory like

james at james-desktop:~$ ls -l /lib/modules/`uname
total 48
-rw-r--r-- 1 root root 49024 2010-12-02 11:04 hdpvr.ko

I can also look at the time/date for the rest of the kernel modules as
installed by the Ubuntu package like this:

james at james-desktop:~$ ls -ld /lib/modules/`uname -r`/kernel/drivers/m*
drwxr-xr-x  2 root root 4096 2010-12-02 08:13
drwxr-xr-x  7 root root 4096 2010-12-02 11:04
drwxr-xr-x  4 root root 4096 2010-12-02 08:13
drwxr-xr-x  4 root root 4096 2010-12-02 08:13
drwxr-xr-x  2 root root 4096 2010-12-02 08:13
drwxr-xr-x  6 root root 4096 2010-12-02 08:13
drwxr-xr-x  4 root root 4096 2010-12-02 08:13
drwxr-xr-x 10 root root 4096 2010-12-02 08:13

From the second command I can see that I installed the current kernel
package on 2010-12-02 08:13. I then recompiled the new drivers and
installed them on 2010-12-02 11:04. Post the output of those two
commands to make sure that the new driver is installed in the correct

mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list