[mythtv-users] Hauppauge HVR-4000

Stephen Robertson stephengrobertson at gmail.com
Fri Nov 27 10:08:32 UTC 2009

2009/11/26 Erwin Panen <erwinpanen at fastmail.fm>:
> Stephen,
> Thanks for replying.
> Within MythTV - not far at all :-(
> -     I'm working on two separate setups each residing within their own hd
> partition to keep things separated.
>        Actually my goal is to get this to work with LinuxMCE, hence Kubuntu
> 0810 based.
>        As I seem to also run into LMCE specific problems, I want to get it
> working on a stock Kubuntu 0810 too.
> -    What do I have?
>        I used liplianin drivers but am open to change to whatever will make
> this work.
>        With the liplianin drivers in place, the firmware gets loaded, and
> the card is properly registered. (dmesg)
>        From that point: Kaffeine will see dvb:0 and dvb:1 and will
> successfully scan dvb:1 (dvb-t) for channels.
>        So Kaffeine viewing works with audio and image.
> -      With dvb-utils -> scan I have managed to scan for channels >
> channels.conf
>        I put this file in ~/.tzap/channels.conf but seem to be unable to get
> this information into MythTV.
> -      Next when installing mythtv v0.21 I need to put in place a fake
> /dev/adapter1 next to existing /dev/adapter0
>        all /dev/adapter/0/***1 devices are symlinked to the new fake
> /dev/adapter1/***0 device.
>        Startup mythtv-setup gave me the usual quirks (admittedly I'm not a
> MythTV expert (yet :-) )
>        When entering capture cards, I can select the DVB DTV Capture card
> (v3.x)
>        with the symlinks in place, I can then change to DVB device: 1
>        And here it ends.
> At the moment I'm even delving into how to modify settings directly into
> mythconverg database.
> I have webmyth installed too, so this can also help to make adjustments.
> So resuming:
> I'm looking for how to link /dev/dvb/adapter* correctly into mythconverg
> and looking for how to get my channel.conf into mythconverg
> If you need more information, let me know.

I know nothing about LinuxMCE so this may not be appropriate but is
there a reason why you couldn't try kubuntu 9.10 with MythTV 0.22?
With this combination it works without any extra drivers,symlinks,
channel.conf importing or database fiddling. (Well it did for me!)

More information about the mythtv-users mailing list