[mythtv-users] Recording Snapshots?

Michael T. Dean mtdean at thirdcontact.com
Sun Nov 15 18:48:10 UTC 2009

On 11/15/2009 12:15 PM, Joe Wilson wrote:
> On Sat, Nov 14, 2009 at 18:09, Michael T. Dean wrote:
>> On 11/14/2009 07:28 PM, Joe Wilson wrote:
>>> In my recordings the snapshots are nothing but 1x1 pixel in size.. they
>>> come
>>> in a variety of browns?
>>> Im curious as to what could be causing this problem..
>> Known issue with analog frame grabbers for a long time.  You get the color
>> of the upper left-most pixel.
> Thanks for the quick response to my post.
> It appears as though Im in need of updating some of my hardware, which is
> long
> passed do. But until then I have tossed together a cronjob to take
> screenshots,
> since i don't appear to be having a problem with mplayer or ffmpeg from a
> terminal.
> I know its not the cleanest way of doing it but it is working for the
> moment, so until
> I can replace my tuner, it will have to do.. lol

If you can come up with a patch for the bug, we can get it fixed for
everyone.  It just happens to be way down low on my TODO list since I
have only ATSC tuners, so it's not really affecting me.

It may not even happen in all cases, too.  I tried doing a lossy
transcode on my dev box (making an MPEG-4 in NUV file) to see if things
worked, and couldn't get the invalid preview images, so it might be
fixed in 0.22-fixes and trunk.  If you're still using 0.21-fixes, you
might want to try upgrading to see if it's fixed (and, if so, I'd
appreciate your letting us know--so I can take that off my TODO list :).

Then again, looking at the last time I saw this pop up on the list (
http://www.gossamer-threads.com/lists/mythtv/users/365971#365971 ), it
seems at that time, I thought it was only RTJPEG in NUV.  (Can your
system handle encoding to MPEG-4 in NUV in real time?)

Still, I'd love a patch.  :)


More information about the mythtv-users mailing list