[mythtv-users] HD-PVR giving up - SOLVED

Marius Schrecker marius at schrecker.org
Fri Nov 6 06:57:36 UTC 2009

>On Wed Nov  4  3:25 , Kenneth Emerson <kenneth.emerson at gmail.com> wrote:On Tue, Nov 03, 2009 at 02:21:58PM -0600, Kenneth Emerson wrote:
>> >
>> >
>> > ...sounds like a frontend that doesn't have enough horsepower to play back
>> > the recording in question. I got a similar result when I tried to play back
>> > a 720p HDPVR recording on an AppleTV.
>> >
>> > [deletia]
>> >
>> >   Depending on your frontend gear, you might want to lock your cable box
>> > into a lower resolution. I had mine at 480p to accomodate my slower
>> > frontends like the AppleTV.
>> >
>> Jedidiah:
>> Thanks for your feedback.  I'm running a Q6600, 2.4Ghz quad core, so I don't
>> think this is a CPU issue.  My OTA recordings at 1080i are rendered fine
>> without using VDPAU.  I believe that the problem is actually in the
>    OTA, eh? Yes. I have similar problems myself. Anything OTA that has
>visible blockiness tends to make the trunk internal player crash. I can
>play the recordings back fine with any other player.
>> recording itself, not in the playback.  I transferred a small piece of the
>> video to a Windows laptop and played it with vlc with the same results.  I
>> haven't played with any of the bitrates available through the v4l-ctl
>> utility.  This may have some impact on the output.  I'll try to play with
>> this later.
>    HDPVR recordings (assuming you are in the US) are much more system
>intensive than OTA recordings. MPEG2 is easy. h264 can be downright hard.
>______Thanks, I stand corrected.  After some experimenting I now understand how much more intensive H264 is to decode than mpeg2 which I guess is why so much attention has been paid to VDPAU and the NVIDIA driver. Until I got the HD-PVR working I haven't had to deal with it at all. Just goes to prove the rule of inverse knowledge ("the less you know about something, the more it can do").
>-- Ken_________________________________________
>mythtv-users mailing list
>mythtv-users at mythtv.org


 Just thought I'd post back with my experiences.  Turned out that my main problem was a combination of the older firmware not being properly updated, and a loose component cable. 

Updating the Hauppauge firmware via windows VM (virtualbox) turns out to be a bit hit and miss, as the process sometimes freezes before finishing (all the coloured lights on the hd-pvr stay on after the upgrade is apparently finished - and after a power cycle, the firmware version is not updated). I managed to run a complete cycle and got my firmware up to version 0x12f.
The error message was then different, and catting /dev/video0 also didn't work, so I played around with the cables at the back of my set-top box, and suddenly everything started working. I'm also using vdpau "normal" profile on my 9400 gt.
 Only TV capture issue now seems to be not exactly jitter, but an occasional corrupted frame, looks like a slight glitsh in the picture quality and comes not regularly, but frequently enough to be annoying. The wife noticed it at once and used it as another argument against using a pc for anything TV related. I'm running on a dual core Opteron, so the issue could be frequency scaling related. Will try changing the threshold.



More information about the mythtv-users mailing list