[mythtv-users] HD-PVR giving up

JEDIDIAH jedi at mishnet.org
Tue Nov 3 20:09:10 UTC 2009

On Mon, Nov 02, 2009 at 10:32:56PM -0600, Kenneth Emerson wrote:
> On Fri, Oct 30, 2009 at 3:29 PM, Ron Garrison <ron.garrison at gmail.com>wrote:
> > You could try setting the hdpvr_debug level in the kernel level
> > options to see if dmesg might give you some info.
> >
> > I just got my hdpvr working last night, and the little I've played
> > with it it seems to be working quite well.  I compiled from the
> > 22-fixes branch which I updated last night.  What I learned along the
> > way (which probably has no bearing on your issue, but you never know -
> > it might trigger something to try).
> >
> > If you have SP/DIF selected, but your optical is not hooked up (or you
> > hooked it to the output instead of the input like I did), the
> > recording will fail.
> >
> > The patches mentioned on the wiki page turned out to be very important
> > for me.  Without the patches, It would work until I changed a channel.
> >  Not sure if mythbuntu incorporates these or not.
> >
> > I have my box set at 720P I believe (I did this a long time ago and
> > haven't gone back to verify), but the wiki indicates this should no
> > longer be an issue.  I was planning on experimenting this weekend.
> >
> > I am using VDPAU and haven't tryed without.  It was so easy to setup
> > and worked out of the box.  I'm running an i5 (2.66 GHz) and during
> > live TV I get 1 to 2% CPU usage on one of the CPUs.
> >
> > Hopefully something will point you in the right direction.  Good luck.
> >
> > Ron
> >
> I just wanted to add my 2 cents in here with my experience with the HD-PVR.
> I've been trying to get this working for about 4 weeks (not solid, I have
> been using the firewire successfully in the interim).  I had a fairly recent
> firmware installed out of the box (0x0f), but try as I might using the
> information in the HD-PVR wiki, the backend would fail on all recording
> attempts.  I started over by upgrading the firmware at Hauppaugue web site.
> It now sits at 0x12.  After re-adding the HD-PVR to the backend, I actually
> got a recording to be made with no errors in the log file; however, the
> recording itself was unwatchable.  The recording would "stutter"; it would
> play fine for 2-5 seconds then stop as if it had been paused on a single

...sounds like a frontend that doesn't have enough horsepower to play back
the recording in question. I got a similar result when I tried to play back
a 720p HDPVR recording on an AppleTV.


   Depending on your frontend gear, you might want to lock your cable box
into a lower resolution. I had mine at 480p to accomodate my slower 
frontends like the AppleTV.

More information about the mythtv-users mailing list