[mythtv-users] mce remote (lirc) fails after resume from standby

Alan Marchiori alan at alanmarian.com
Tue Jun 30 16:01:55 UTC 2009

>>> Yes, this is more or less the same lirc version mis-match biting Fedora
>>> 10
>>> users in the ass right now. There were incompatible changes between the
>>> 0.8.4 and 0.8.5, so you need to make sure if you're building your own
>>> driver
>>> that it matches your available userspace. I'd suggest you try patching
>>> the
>>> driver in lirc 0.8.4a instead of the latest lirc release or cvs if
>>> updating
>>> your userspace to match isn't practical.
>> I got 0.8.5 working ... ubuntu had lircd in /usr/sbin the make install
>> put lircd in /usr/local/sbin
>> I removed the files (lircd and lircmd) in /usr/sbin and made symlinks
>> in /usr/sbin pointing to /usr/local/sbin.
>> Worked on the first try.  I did one suspend-resume cycle and it also
>> seems to have solved the suspend-resume issue.
> A better fix would be at the configure stage specify prefix
> ./configure --prefix=/usr
> That will ensure that the install goes to the right place

maybe; either way since apt thinks I have 0.8.4a installed if it wants
to update it will overwrite the files whether they are symlinks or

I'm sure there is some way to tell apt not to update the lirc package,
but I don't know it.

Hopefully it won't be an issue very often.

More information about the mythtv-users mailing list