[mythtv-users] Problems with remote on FC10, lirc_serial and Kernel

Jarod Wilson jarod at wilsonet.com
Tue Jun 30 03:24:21 UTC 2009

On Jun 29, 2009, at 10:01 PM, Michael Jones wrote:

> I have a FC10 installation of MythTV on my office front end that's  
> having a problem.
> I just upgraded this from FC8 to FC10.  It worked VERY well in FC8  
> but has subsequently broken.
> I'm running:
> FC10 with kernel
> LIRC 0.8.5-2.fc10
> I've tried so many different combinations that what I have and  
> haven't tried is getting fuzzy.. :-s

2.6.27.x + lirc 0.8.5 is busted, you need to back off to lirc 0.8.4a  
for the moment. 2.6.29.x + lirc 0.8.5 works, except for the fact  
lirc_serial is busted in the Fedora 2.6.29.x kernels at the moment.  
However, I think I've finally got a fix for that, about to test it out  
on actual hardware in a sec... If I do have it fixed, I'll push a some  
new Fedora kernel builds and provide folks with links to it for testing.

> I've heard that you need to completely disable the serial driver in  
> FC10 for it to work.. How's this done?

setserial /dev/ttySX uart none

Jarod Wilson
jarod at wilsonet.com

More information about the mythtv-users mailing list