[mythtv-users] Problems with remote on FC10, lirc_serial and Kernel

Michael Jones mythtv at michaelandholly.com
Tue Jun 30 02:01:53 UTC 2009

I have a FC10 installation of MythTV on my office front end that's  
having a problem.

I just upgraded this from FC8 to FC10.  It worked VERY well in FC8 but  
has subsequently broken.

I'm running:

FC10 with kernel
LIRC 0.8.5-2.fc10

I've tried so many different combinations that what I have and haven't  
tried is getting fuzzy.. :-s

I've tried both yum pre packaged binaries and custom compling the LIRC  
software with no changes (custom compile seems to have more problems  
than yum prepackaged)

I've tried everything I can find with combinations of setserial,  
modprobe etc commands with no improvements.  LIRC loads just fine, but  
won't recognize the remote at all in irw or irrecord.

I've tried multiple combinations of switching the serial port back and  
forth.. switching the modprobe.conf options.. loading via  
modprobe.conf.. nothing seems to work.

I've heard that you need to completely disable the serial driver in  
FC10 for it to work.. How's this done?

The remote that I have is the mp3anywhere setup from X10.

Is there anyone with a similar (or identical) configuration?  Is this  
a known issue?  Do I just need to wait until it's fixed, or should I  
downgrade to a different version of the LIRC software?

I'm about at wits end with this.. and looking for some help.  Thanks.

- Michael

More information about the mythtv-users mailing list