[mythtv-users] Long delays with remote occasionally

Jason Weida jason.m.weida at gmail.com
Mon Sep 8 13:13:52 UTC 2008

On Sun, Sep 7, 2008 at 7:31 PM, Sean Cier <scier at posthorizon.com> wrote:

> Another data point.  One of my frontends did this, a lot -- half the
> time I tried to do something, it'd take two minutes or more to realize
> I'd hit a button.  Made it completely unusable -- who wants a DVR that
> won't pause?
> -- It is *not* lirc: when the problem popped up, both my remote and my
> (non-lirc) IR keyboard did exactly the same thing.
> -- Started right after a "latest FC8" -> "latest FC9" upgrade a couple
> days ago (both on -fixes via atrpms).  *Never* happened before that, and
> this hardware's been running a frontend for over four years (the latest
> clean reinstall was at least a few months ago).
> -- Turning on OpenGL sync seems to have made the problem nearly go
> away.  I have observed it once since then (in about 1.5 evenings of usage).
> -- I only ever observed it during playback, not in menus (SDTV; this
> thing's /just/ powerful enough to play most 720p HDTV streams pulled off
> cable, but I don't have any at the moment because my backend doesn't get
> along with my cable box over firewire lately.  Gonna buy an HDHR as soon
> as Amazon's price goes down again.  I'd already have it if Amazon hadn't
> canceled their price guarantee policy...)
> -- I only ever observed it after the playback had been running for at
> least a minute or two.  Similarly, once it responded to something, it
> seems like it continued responding for at least a little while.  This
> could be a sampling bias though.
> -- At least some of the commands queued up; I'd hit some buttons, then
> sit and wait for a while, and *usually* eventually they (or at least
> some of them) would take effect, all in a row.  Of course, I've no idea
> what level they queued up at.  I *know* keyboard commands queued up, but
> I'm not 100% certain I observed lirc events queue up.  The keyboard
> always seemed to provide a higher chance of actually working, eventually.
> -- Changing playback profiles, video-as-timebase, extra-audio-buffering
> had no effect.  Enabling realtime threads didn't either, but I didn't
> verify changing that setting actually worked on the system, so it
> could've been a no-op anyhow.
> -spc
Good points, I'm seeing the same.  Playback only, other menus work just
fine.  Next time it happens to me, I'll check that screensaver/xorg business
in the other thread, but it sounds a like a different issue since keyboard
commands are not responding as well (I have a wired PS2 keyboard).  It
sounds like everyone who has observed the problem is using a lower end
machine, so maybe that's part of the issue.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080908/853e86b1/attachment.htm 

More information about the mythtv-users mailing list