[mythtv-users] Compatibility with HDTV card

David George david at thegeorges.us
Mon Jun 23 15:45:15 UTC 2008

On 06/22/2008 10:38 PM, Harry Orenstein wrote:
> I have an HDTV Wonder card (the original, PCI).  It works fine and the drivers 
> load at boot without problem.  The issue I'm running into is that the 
> firmware fails to load when mythbackend starts during boot.
> One of two things happens: either the firmware fails to load with many 
> messages ending in 'IRQ loop detected, disabling interrupts' or with no 
> messages at all.  In either case, the driver is loaded properly, but the 
> device is unavailable in mythfrontend.  When I try to access the cardinput in 
> myth it appears to be in use, and unavailable.  If I restart mythbackend, the 
> firmware loads successfully during the restart and the cardinput is available 
> in myth.
> I'm running Fedora 8 and starting mythbackend in an init script.  I've tried 
> forcing the cx88_dvb module to load in rc.local, without improvement.  If I 
> try to access the card using 'mplayer dvb://' the firmware then loads 
> correctly and I can see video from the card, even if mythbackend is in the 
> above 'failure' mode (but it doesn't improve access to the cardinput, I still 
> have to restart mythbackend for that).

rc.local is run after all other scripts have run so it is too late in 
the boot process to add modprobe.

Here is a link to an old message I posted on this very subject.  Replace 
references to ivtv with your cx88_dvb and see if that helps.



More information about the mythtv-users mailing list