[mythtv-users] osx-packager doesn't build Qt?

scram69 scram69 at gmail.com
Thu Jun 12 17:39:48 UTC 2008

On Thu, Jun 12, 2008 at 9:46 AM, David Snider <dsnider at thesniderpad.com> wrote:
> scram69 wrote:

>> Well, I tried again... this time, I get osx-packager.pl from
>> http://svn.mythtv.org/trac/browser/branches/release-0-21-fixes/mythtv/contrib/OSX/osx-packager.pl
>> and run
>> perl osx-packager.pl -svnbranch release-0-21-fixes
>> However, I still get the same error about not finding Qt installed!
>> Am I still not using the correct combination of script and option in
>> order to build 0.21-fixes?
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> Hmm, that is a bugger.   When you pulled down the different
> osx-packager.pl script, did you blow away the .osx-packager directory
> from the current working directory?  Or did you start the "perl
> osx-packager.pl -svnbranch release-0-21-fixes" in a different
> directory?

I completely blew away the old .osx-packager directory before I
downloaded and ran the different script.

The reason I ask is that by default the osx-packager script
> will reuse any compiled dependencies if it finds them in the
> .osx-packager directory.  And if one version of the osx-packager didn't
> compile QT threaded, and the other did, well, you'd still get the error
> as both would see the compiled dependency and "just use it".
> If you only want the release-0-21-fixes, you *could* just download it
> from thesniderpad.com.  (Unless you need it universal, can't remember
> what platform you were on).

I have an intel mini, along with a _lot_ of ripped .iso files in
/videos, which the 0.21 release won't play (it was fixed in -fixes).
Thus my desperation to get 0.21-fixes working.

I've tried Grant Kwok's binary at http://macvana.com/mythtv/FIXES/,
which he recently re-built, but all I get when I try to launch his app
is "Bus error".  It won't even start a log file to tell me what's
wrong.  Have you ever seen that?

At any rate, with /buld/lib/ full of libQt*.dylib files, it seems that
for some reason, Qt is being compiled non-threaded.  I guess what I
have to do is go back through the Qt compilation and try and figure
out why...

More information about the mythtv-users mailing list