[mythtv-users] MythArchive totally screwed up after update to 0.21

Torsten Crass torsten.crass at bioinf.med.uni-goettingen.de
Thu Jun 12 08:40:38 UTC 2008

Hi Paul,

removing the old archiveitems from the database really did the trick -- 
works like a charm now! :-)

> Basically it gets passed to the script in the job file.  The  filename 
> including the path gets stored in the archiveitems table when you select 
> recordings to archive. Later when the job file is created the full 
> filename is added to the job file. 

Of course -- stupid question of mine...

> If you had some old entries in the 
> archiveitem table that don't have the full path to the recording then 
> bad things can happen.

Yes, I have in fact been messing around with an old job file...

> Looks like projectx actually creates the X.ini config file in the 
> current directory.  Maybe changing to your HOME directory before running 
> the FE  will work? That way it should always be able to find its config 
> file and wont nag you to confirm the license agreement.

Couldn't have worked anyway the way I initially tried to use ProjectX... 
I put a one-liner shell script into /usr/local/bin which just called 
"java -jar /path/to/projectx/ProjectX.jar", not taking into 
consideration that 1) by this all command line arguments possibly given 
would be discarded and 2) ProjectX wouldn't find some of its required 
libraries since it wasn't run from its /path/to/projectx directory. 
Corresponding changes finally let ProjectX smoothly integrate with 

Yet it seems I've recorded some shows with audio problems that bad that 
not even ProjectX could cope with them -- in these cases dvdauthor still 
complains about not being able to jumpt to chapter something blabla. 
Using a chapter-menu free theme, however, circumvents this problem.

Paul, as for mplex, what would you think about always calling it with 
the "-M" flag given additionally to prevent it from complaining about a 
missing "%d" in its outfile name when it encounters a sequence end 
marker and hence tries to generate multiple numbered outfiles?

Best regards --


More information about the mythtv-users mailing list