[mythtv-users] Mythfrontend Freezes on Video Playback

Mache Creeger mache at creeger.com
Wed Jan 16 17:31:33 UTC 2008

Before I upgraded the Nvidia drivers from 100 to 169, video playback 
(both Watch TV and Play Pre-recorded) worked perfectly.

After the upgrade I get a black screen that freezes mythfrontend.

Any ideas?

-- Mache Creeger

I am running Fedora 7, kernel, and have the atrpms 
169.07 nvidia rpms as per wilsonet instructions, and have a Nvidia 
6200 AGP video card.   I erased and reloaded the nvidia 169.07 
drivers once already. I have used the nvidia-grpahics-switch to set 
drivers to 169.07.

Here is some log information from the execution of mythfrontend from a shell

2008-01-16 09:12:40.126 TV: Attempting to change from None to 
2008-01-16 09:12:40.261 DPMS Deactivated
0: start_time: 0.036 duration: 323.672
1: start_time: 0.017 duration: 323.674
stream: start_time: 0.189 duration: 3596.571 bitrate=5194 kb/s
2008-01-16 09:12:40.430 AFD: Opened codec 0xb2f8c20, 
id(MPEG2VIDEO_XVMC) type(Video)
2008-01-16 09:12:40.431 AFD: Opened codec 0xb2f0ac0, id(MP2) type(Audio)
2008-01-16 09:12:40.464 Opening OSS audio device '/dev/dsp'.
2008-01-16 09:12:40.922 VideoOutputXv: XvMCTex: Init failed
2008-01-16 09:12:40.923 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
   Major opcode:  141
   Minor opcode:  14
   Resource id:  0x1a6
2008-01-16 09:12:40.946 NVP: Forcing decode extra audio option on.
                         XvMC playback requires it.
2008-01-16 09:12:42.886 TV: Changing from None to WatchingPreRecorded
2008-01-16 09:12:42.890 Realtime priority would require SUID as root.
XvMC: picture structure FRAME

# more /etc/X11/XvMCConfig

# ls -al /etc/X11/XvMCConfig
-rwxr-xr-x 1 root root 27 2008-01-16 08:27 /etc/X11/XvMCConfig

# locate libXvMCNVIDIA_dynamic.so.1

# ls -al /usr/lib/nvidia-graphics-169.07/libXvMCNVIDIA_dynamic.so.1
lrwxrwxrwx 1 root root 23 2008-01-16 09:01 
/usr/lib/nvidia-graphics-169.07/libXvMCNVIDIA_dynamic.so.1 -> 

# rpm -qa | grep nvidia

# more /etc/X11/xorg.conf

# Xorg configuration created by system-config-display

Section "ServerLayout"
         Identifier     "single head configuration"
         Screen      0  "Screen0" 0 0
         InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
         ModulePath   "/usr/lib/xorg/modules/extensions/nvidia"
         ModulePath   "/usr/lib/xorg/modules/extensions"
         ModulePath   "/usr/lib/xorg/modules"
         FontPath     "unix/:7100"

Section "Module"
         Load  "dbe"
         Load  "extmod"
         Load  "fbdevhw"
         Load  "glx"
         Load  "record"
         Load  "freetype"
         Load  "type1"
         Load  "v4l"

Section "InputDevice"
         Identifier  "Keyboard0"
         Driver      "kbd"
         Option      "XkbModel" "pc101"
         Option      "XkbLayout" "us"

Section "Monitor"
         Identifier   "Monitor0"
         VendorName   "Dell"
         ModelName    "M1110"
         HorizSync    30.0 - 107.0
         VertRefresh  150.0 - 160.0
         Option      "dpms"

Section "Device"

#       Option      "RenderAccel" "1"
#       TV Out Setup
         Identifier  "Videocard0"
         Driver      "nvidia"
         VendorName  "nVidia"
         BoardName   "6200"
         Option      "TVStandard" "NTSC-M"
         Option      "TVOutFormat" "SVIDEO"
         Option      "UseEvents" "True"
# Eliminate VVMC Error
         Option      "XvmcUsesTextures" "False"
         Option      "NvAGP" "3"
         Option      "NoLogo" "True"
         Option      "RenderAccel" "True"

Section "Screen"
         Identifier "Screen0"
         Device     "Videocard0"
         DefaultDepth     24
         SubSection "Display"
                 Viewport   0 0
                 Depth     24
                 Modes    "1024x768" "832x624" "800x600" "720x400" 
"640x480" "640x400" "640x350"

Section "DRI"
         Group        0
         Mode         0666

More information about the mythtv-users mailing list