[mythtv-users] What to expect when you're expecting FireWire

Martin Lynch martin.lynch at shaw.ca
Tue Jan 8 10:49:47 UTC 2008

Message: 1
Date: Mon, 7 Jan 2008 21:39:22 -0500
From: "Ryan Steffes" <rbsteffes at gmail.com>
Subject: [mythtv-users] What to expect when you're expecting FireWire
To: "Discussion about mythtv" <mythtv-users at mythtv.org>
	<674c6cd30801071839p770a6b83p1886ccf0a3cf661a at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1

I've just recently made the jump to digital cable when I worked out
that I could save $3 a month with a bundled cable/internet promotion
Time Warner was running here in Raleigh.  Since I don't have an HDTV,
I'm more or less intellectually satisfied with using an IR Blaster and
capturing from SVideo.  I wanted to try getting the firewire interface
working first though, but what I quickly discovered is that there's
not a lot of leeway in between working and not working.

The box seems to be detected fine, which actually is what's confusing
me.  If it wasn't being detected AT ALL, I'd just say the ports
weren't working and debate going to raise a fuss.

Upon plugging in, dmesg shows:

ieee1394: Node added: ID:BUS[0-01:1023]  GUID[001cea0a3cc20000]
ieee1394: raw1394: /dev/raw1394 device initialized
ieee1394: Node suspended: ID:BUS[0-01:1023]  GUID[001cea0a3cc20000]
ieee1394: Node resumed: ID:BUS[0-01:1023]  GUID[001cea0a3cc20000]

plugreport shows:

Host Adapter 0

Node 0 GUID 0x000199000009e2bd
libiec61883 error: error reading oMPR
libiec61883 error: error reading iMPR

Node 1 GUID 0x001cea0a3cc20000
oMPR n_plugs=1, data_rate=2, bcast_channel=63
oPCR[0] online=1, bcast_connection=0, n_p2p_connections=0
        channel=0, data_rate=0, overhead_id=0, payload=146
iMPR n_plugs=0, data_rate=2

But test-mpeg2 just gives:

 libiec61883 warning: Overlayed connection on channel 0.
You may need to manually set the channel on the receiving node.
Starting to receive

and sits until I kill it.

And firewire_tester just gives a long string of fail:
./firewire_tester -n 1 -p -r 10
Action: Test P2P connection 10 times, node 1, channel 1
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed
P2P: Testing...Failed

Any suggestions while I wait on the ir blaster I ordered to arrive?


I'm not familiar with your STB (mine's a Motorola 6200), but a couple of 
things to check out/try:

- go into mythtv-setup, delete your firewire capture card (in 2. Capture 
Cards), unplug your STB, wait 10 secs, plug it back in, give it a minute 
to start up and then add your firewire again (if you haven't waited long 
enough the GUID won't appear). Select "Broadcast" rather than P2P - at 
least on my 6200 it's WAY more stable - and set speed to 400. Make sure 
you give it a connection in 4. Input Connections.

- Try: 

./firewire_tester -B -P 0 -n 1

This will attempt to stabilize the broadcast connection.

- If that still doesn't help, try resetting your bus - I use a program 
called gscanbus - just google it and compile it, then type gscanbus in a 
terminal. A box will pop up identifying all your firewire connections. 
Hit the Force Bus Reset button, then run firewire tester as above.

If that still doesn't work, perhaps some sort of DRM is being employed 
by your cable co - either CCI or 5C. There should be a way to access an 
onscreen menu for you STB and determine which, if any, channels are copy 
protected (and therefore unwatchable via the firewire) and also what 
form of copy protection is being used, tho I can't tell you how to do 
that on your particular box...

My firewire connection has been pretty solid for months now.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080108/1e6a4e5d/attachment.htm 

More information about the mythtv-users mailing list