[mythtv-users] Database update schema error with trunk utf8

freedenizen freedenizen at gmail.com
Wed Dec 17 01:21:08 UTC 2008

On Tue, Dec 16, 2008 at 4:19 PM, Michael T. Dean
<mtdean at thirdcontact.com> wrote:
> Can you explain exactly how you got the database that failed to
> upgrade?  I.e. were you running MythTV 0.21 and then upgraded MythTV in
> place (on the same host and didn't touch the database at all) and then
> tried to upgrade the database by running either mythtv-setup or
> mythbackend?  Or, did you restore a backup of a database (at any time on
> the system) before the initial upgrade failure?

I was running .21-fixes and upgraded to trunk in place, didn't touch
the database except to make the backup.

I tried to upgrade the database by using mythtv-setup

It is quite possible that I did a restore at some point in the history
of running myth, in fact I am positive I have.  I was able to
replicate the error, after dropping the database and restoring it,
both just doing a straight restore, and after creating the database
with mc.sql and then restoring the data.

> What distro are you running?  Does the distro do stuff to help set up
> your database for you?

I am using gentoo, but I have never installed myth through gentoo,
always compiled from source.  mysql was install through gentoo with
the following use flags:
[ebuild   R   ] dev-db/mysql-5.0.70-r1  USE="berkdb perl ssl
-big-tables -cluster -debug -embedded -extraengine -latin1
-max-idx-128 -minimal (-selinux) -static"

More information about the mythtv-users mailing list