[mythtv-users] Newbie - Problem w/ Hauppage TV card

Mitch Gore mitchell.gore at gmail.com
Fri Sep 7 14:56:04 UTC 2007

n 9/7/07, Vaughn Treude <vltreude at deru.com> wrote:
> Hello everyone,
> I'm new to the group - haven't gotten into Myth TV yet.  At present I'm
> still struggling with my TV card.
> Here's the background - I had a Hauppage TV card (which I used for video
> capture) running fine under Mandrake 10.  Then the system's motherboard
> died, taking the Hauppage card with it.  I recreated the system on a new
> mobo, installing Mandrake 2005 (mainly because I had a set of those CD's
> laying around.)  So I got everything reinstalled and working on that.  I
> just needed a new TV card.  I recently purchased a Hauppage PVR-150, and
> although the system detects its presence, the card won't work.  I've
> downloaded IVTV drivers for my kernel (the old 0.49 versions for 2.6.11)
> and those load without error, but will not talk to the card.
> All of the "how to" instructions I've found so far say you should test
> by doing a "cat" from /dev/video0.  The problem is that on my system
> this device doesn't exist.  One of the "how to" documents said you could
> create the /dev/video* devices manually, which I tried, but they were
> gone after reboot.  So I imagine that udev (if I understand its purpose
> correctly) isn't seeing the card.  Do you think this might indicate that
> the Hauppage might be bad?
> Another bit of info: this is a dual-boot system, with Windows 98 on the
> other partition.  I tested the previous TV card first under Windows, and
> it worked right away.  But the drivers that came with the PVR-150 are
> for XP, so although Windows detected and identified the card correctly,
> the drivers wouldn't install.  After some searching, I downloaded a
> driver that might _possibly_ be right for the PVR-150 (it was supposed
> to support all cards with its particular chipset), but they didn't work
> either.  When I try to start WinTV 2000 it says it can't find some sort
> of filter device.  That could mean the card's bad, I suppose, or it
> could just be the wrong driver.
> I'm thinking I may be missing some video components on Linux, since it
> doesn't create /dev/video* and I haven't tried a TV card before on this
> install.  But it doesn't seem likely, as I've downloaded and installed
> the many, many video-related packages and managed to get Xine working
> and playing DVDs.  So I'd think Mandrake should detect and configure the
> card without any trouble, so maybe it _is_ bad.  But I'm still hopeful
> that I won't have to return the thing.  Any suggestions of video-type
> packages that I might have missed?  (I suppose I could try upgrading to
> kernel 2.6.18 as the IVTV docs suggested, so I can get more recent
> drivers, but I think my problem is more fundamental than that.)
> Thanks,
> Vaughn

Upgrade to a newer distro.  Fedora and Ubuntu are popular.  I would even
suggest MythDora.  It has all drivers, etc for an entire myth system put
into the system installer.  It will whipe that 98 install, do you really
need it?

With fedora ivtv is as simple as intstalling the ATRPMS's repo and then -

yum install ivtv
yum isntall ivtv-firmware

depmod -a
modprobe ivtv

And now it works.

I dont know much about Mandriva, just letting you know there are alot easier
distro out there.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070907/6a3acf2a/attachment.htm 

More information about the mythtv-users mailing list