[mythtv-users] Hauppage remote - I've had numbers and keys working, but nothing else.

David Watkins watkinshome at gmail.com
Fri Nov 30 10:48:03 UTC 2007

> foiled at the first hurdle!
> irrecord -H dev/input -d /dev/input/event6 mylircd.conf
> gave me permission problems, so I ran
> sudo irrecord -H dev/input -d /dev/input/event6 mylircd.conf
> this gave me the introductory text and then:
> "Hold down an arbitrary button"
> I pressed one of the buttons on the remote and held it down. After a few
> seconds, I got:
> irrecord: gap not found, can't continue
> irrecord: closing '/dev/input/event6'

I do remember see that error.  I wonder if i's anything to do with the
evdev stuff I put in my xorg.conf?

> > Section "InputDevice"
> >         Identifier "remote"
> >         Driver "evdev"
> >         Option "Name" "Hauppauge Nova-T"
> >         Option "XkbModel" "evdev"
> >         Option "Protocol" "evdev"
> >         Option "Device" "/dev/input/event4"
> > EndSection

I remember on my first build (Fedora Core 3) I had to modprobe the
evdev driver, but when I rebuilt using (Fedora Core 6) the evdev
driver module had disappeared and I found the magic incantantion
above.  I can't remember if I ever checked whether the irrecord
statement worked without it though.

I guess it woouldn't hurt to add that block to your xorg.conf, restart
X, and see what happens.

Otherwise I'm out of ideas.

More information about the mythtv-users mailing list