[mythtv-users] Hauppage remote - I've had numbers and keys working, but nothing else.

Damian damian at gingermagic.co.uk
Thu Nov 29 14:36:26 UTC 2007

David Watkins wrote:
> On 28/11/2007, Damian <damian at gingermagic.co.uk> wrote:
>> Hello all,
>> I've just posted to a thread regarding the Hauppage remote on a
>> Mythbuntu foum, but thought I'd ask here too.
>> I've never managed to get my remote to work. Pre or post Mythbuntu. I
>> was hoping that Mythbuntu would sort it out (one of my main reasons for
>> installing it on top of my Ubuntu/Mythtv system), but still nothing. I
>> have number keys and directional key working, but pretty much nothing
>> else so I have to use my keyboard all or the time.
>> I have 2 Hauppage Nova-t cards in my machine and a long ir cable coming
>> out of one of them (I actually spliced two together to make it long
>> enough, but there is input getting in so i don't think that's causing a
>> problem).
>> The person who started the thread I repled to got things working after
>> he seilised that his remote was recognised by the kernel and followed
>> some advice here:
>> http://parker1.co.uk/mythtv_ubuntu2.php
>> I have just re-looked at the parker site and ran
>> cat /proc/bus/input/devices
>> where I find I have 2 Hauppage entries (to be expected), on event 5 and
>> evern6.
>> Running
>> sudo evetest /dev/input/event5
>> doesn't do much, but
>> sudo evetest /dev/input/event6
>> fills me with hope. Everything I press suddenly does give me a response!
>> I don't understand the responses, but they're there
>> However, when I go down further to the part where it says:
>> As usual, we'll give it a quick test ...
>> sudo /usr/sbin/lircd -H dev/input -d /dev/input/event2 -n
>> and (in another terminal)
>> irw
>> "Press some buttons and you should see the events displayed"
>> Well, I see nothing at all displayed! Not even the numbers and cursor
>> keys giving any input now!
> You need to make sure you've got lircd configured right.
> I used
> irrecord -H dev/input -d /dev/input/event6 mylircd.conf

foiled at the first hurdle!

irrecord -H dev/input -d /dev/input/event6 mylircd.conf
gave me permission problems, so I ran
sudo irrecord -H dev/input -d /dev/input/event6 mylircd.conf
this gave me the introductory text and then:
"Hold down an arbitrary button"
I pressed one of the buttons on the remote and held it down. After a few 
seconds, I got:
irrecord: gap not found, can't continue
irrecord: closing '/dev/input/event6'
I tried again and this time press number 1 on the remote. Lots of 
11111111111's came up on screen, and then
irrecord: gap not found, can't continue
irrecord: closing '/dev/input/event6'

Any ideas?
sudo evtest /dev/input/event6
seems to give responsive feedback to all of the buttons on the remote, 
so I don't think anything is completely broken. Maybe just messed up due 
to being configured by a Linux newbie idiot :-)



>  then copy mylircd.conf to /etc/lircd.conf
> then start lircd with
> lircd -H dev/input -d /dev/input/event6 /etc/lircd.conf
> This maps your key-codes to labels.
> You also need an lircrc file where you attach the labels to the mythtv
> key mappings.  See
> http://wilsonet.com/mythtv/fcmyth.php#lirc
> for help with this.
> There's a fairly good wiki page too
> http://www.mythtv.org/wiki/index.php/Hauppauge_WinTV_Nova-T_500_PCI
> I also ended putting this in my xorg.conf file
> Section "InputDevice"
>         Identifier "remote"
>         Driver "evdev"
>         Option "Name" "Hauppauge Nova-T"
>         Option "XkbModel" "evdev"
>         Option "Protocol" "evdev"
>         Option "Device" "/dev/input/event4"
> EndSection
> to get the evdev driver loaded, but I can't remember where I got that
> bit of black magic from.
> Hope this helps
> Hope this helps
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list