[mythtv-users] Hauppage remote - I've had numbers and keys working, but nothing else.

Damian damian at gingermagic.co.uk
Fri Nov 30 11:33:17 UTC 2007

David Watkins wrote:
>> foiled at the first hurdle!
>> irrecord -H dev/input -d /dev/input/event6 mylircd.conf
>> gave me permission problems, so I ran
>> sudo irrecord -H dev/input -d /dev/input/event6 mylircd.conf
>> this gave me the introductory text and then:
>> "Hold down an arbitrary button"
>> I pressed one of the buttons on the remote and held it down. After a few
>> seconds, I got:
>> irrecord: gap not found, can't continue
>> irrecord: closing '/dev/input/event6'
> I do remember see that error.  I wonder if i's anything to do with the
> evdev stuff I put in my xorg.conf?
>>> Section "InputDevice"
>>>         Identifier "remote"
>>>         Driver "evdev"
>>>         Option "Name" "Hauppauge Nova-T"
>>>         Option "XkbModel" "evdev"
>>>         Option "Protocol" "evdev"
>>>         Option "Device" "/dev/input/event4"
>>> EndSection
> I remember on my first build (Fedora Core 3) I had to modprobe the
> evdev driver, but when I rebuilt using (Fedora Core 6) the evdev
> driver module had disappeared and I found the magic incantantion
> above.  I can't remember if I ever checked whether the irrecord
> statement worked without it though.
> I guess it woouldn't hurt to add that block to your xorg.conf, restart
> X, and see what happens.
> Otherwise I'm out of ideas.

Thanks for your help. That weird bit of voodoo seems to have done the 
trick without even using it!! Very weird! I feel like I've not done 
anything that I've not tried before. All still was broken, then I put 
your bit of black magic into xorg and was about to restart X when I 
noticed that the remote was suddenly working properly!
I quickly went into xorg and commented out the evdev voodoo (as I knew 
it couldn't have been used yet and I didn't want to break whatever did 
I've rebooted since and everything seems fine!
Months and months without a remote, and now it's all sorted! My best 
guess is that with a bit more linux experience under my belt, I actually 
put the right files in the right place this time.

Now I can get to tweaking my keys.
Thanks for your help

More information about the mythtv-users mailing list