[mythtv-users] nvidia module won't load

Rich West Rich.West at wesmo.com
Mon Nov 26 18:15:19 UTC 2007

Nick F wrote:
> On 11/26/07, *nowhere at cox.net <mailto:nowhere at cox.net>* 
> <nowhere at cox.net <mailto:nowhere at cox.net>> wrote:
>     ---- Richard Shaw <hobbes1069 at gmail.com
>     <mailto:hobbes1069 at gmail.com>> wrote:
>     > nowhere at cox.net <mailto:nowhere at cox.net> wrote:
>     > > Stupid me. Made the mistake of yum update again. Never works
>     without breaking. Anyway, same ole problem. nvidia module won't
>     load. I did the usual below and then I tried to yum remove and yum
>     install the nvidia drivers but they don't exist. I think I still
>     need the 9631 drivers since my card is integrated on the mobo.
>     Here is a ton of info. Last time I fixed this by creating a
>     symlink to the driver using a different extension but that didn't
>     work this time...
>     > I'm assuming the "yum update" installed a new kernel? I use the
>     nvidia
>     > drivers from freshrpms which includes dkms so every time the
>     kernel gets
>     > updated it rebuilds the module automatically during boot-up. I
>     believe
>     > livna also has a similar package available. If you need older
>     drivers
>     > freshrpms also has a 96xx and 97xx packages as well.
>     eah but I backed off to 4-65 again and all the old drivers
>     wouldn't work anymore. Tried looking how everything was name and
>     it was as it is listed above. So I guess the question is which
>     graphics drivers do I need. I'm pretty sure nothing above 9631
>     works on my card so which one? 
> I had a similar problem, with similar error messages, when using the 
> atrpms drivers on a legacy NVIDIA (integrated card).  I never did 
> solve the problem, and since it was happening around the time ATRPMS 
> was offline, I found the LIVNA driver didn't exhibit the same 
> behaviour.  I only use LIVNA for my NVIDIA drivers, and ATRPMS for the 
> rest.  So - if all else fails - try LIVNA.

I believe the 96xx and 97xx (last one being 9755) were replaced with the 
100.14.xx on atrpms.net.  You'd have to do a "yum install 
nvidia-graphics100.14.19-kmdl-" (assuming you are running 
Fedora) or "yum install nvidia-graphics100.14.19-kmdl-$KVER" (where 
$KVER is your kernel version).

IF you manage to get the kernel installed and the associated 
nvidia-graphics<ver>-kmdl installed and things aren't working right, 
give "nvidia-graphics-switch" a try..

For what it is worth, I recently upgraded my frontends, jumped through 
the nvidia/kernel/atrpms hoops to get the kernel updated, and found that 
there is a "pink screen" problem (I run Fedora, but it's a driver issue, 
http://ubuntuforums.org/showthread.php?t=572057) with the latest 
driver.  Hence, I wanted to back down to my already installed 9755 
driver and the previous kernel.  I ran nvidia-graphics-switch with the 
right options, updated grub.conf to boot the previous kernel, and I was 
back up and running in no time.


More information about the mythtv-users mailing list