[mythtv-users] Compiling latest SVN

Henry A Harper III hah at alumni.rice.edu
Fri Nov 23 15:57:53 UTC 2007

> I wanted to try and see how to compile and use the latest SVN version,
> so I backed up my database, followed the SVN on Fedora Wiki article
> (http://www.mythtv.org/wiki/index.php/Installing_MythTV_SVN_on_Fed
>and compiled everything.  All seemed to work fine, but now when I try to
>start the frontend, I get an error stating: "error while loading shared
>libraries: libmythtv-0.20.so.0: cannot open shared object file: No such
>file or directory".  Also, if I enter mythbackend --version, it tells me
>0.20.2-169.fc6, which is what I was running previously.
>Any ideas on what I'm missing?

You probably have two copies of mythbackend and mythfrontend in different
locations: one from your previous installation via packages, and another one
from your compiled source. The configuration instructions you provided &
make install put the new copies into a directory later in your path than the
old ones, but now when the old ones are started because they're earlier in
the path, they can't find their-version lib files because those did get
overwritten. Easiest fix would be deleting the old mythbackend &

More information about the mythtv-users mailing list