[mythtv-users] Compiling latest SVN

Harry Devine lifter89 at comcast.net
Fri Nov 23 16:18:07 UTC 2007

Henry A Harper III wrote:
>> I wanted to try and see how to compile and use the latest SVN version,
>> so I backed up my database, followed the SVN on Fedora Wiki article
>> (http://www.mythtv.org/wiki/index.php/Installing_MythTV_SVN_on_Fed
>> ora_Core)
>> and compiled everything.  All seemed to work fine, but now when I try to
>> start the frontend, I get an error stating: "error while loading shared
>> libraries: libmythtv-0.20.so.0: cannot open shared object file: No such
>> file or directory".  Also, if I enter mythbackend --version, it tells me
>> 0.20.2-169.fc6, which is what I was running previously.
>> Any ideas on what I'm missing?
> You probably have two copies of mythbackend and mythfrontend in different
> locations: one from your previous installation via packages, and another one
> from your compiled source. The configuration instructions you provided &
> make install put the new copies into a directory later in your path than the
> old ones, but now when the old ones are started because they're earlier in
> the path, they can't find their-version lib files because those did get
> overwritten. Easiest fix would be deleting the old mythbackend &
> mythfrontend.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I just removed all of the preinstalled packages, and ran make install on 
everything again (mythtv, mythplugins, and myththemes), but when I try 
to run either the frontend or backend, I get the same error.  I have 
found the apps in /usr/local/bin, but when I try to run them from 
/usr/local/bin, it says "mythbackend: /usr/bin/mythbackend: no such file 
or directory".  Any thoughts?


More information about the mythtv-users mailing list