[mythtv-users] Can't get system to wake up at set time.

Craig Huff huffcs at yahoo.com
Sat Mar 17 23:23:43 UTC 2007


Thank you for the suggestion.

I take it that you mean the BIOS setting for enabling/disabling the HW alarm clock.  If so, I have tried your suggestion and it didn't work for me.

Note that I had been successful getting the system to wakeup at a set time with the alarm clock enabled in the BIOS if I shutdown using the front-panel soft-power button but not if I let Fedora Core 6 shutdown the system.

I use nvram-wakeup to access /dev/nvram and /dev/rtc instead of using /proc/acpi/alarm because /proc/acpi/alarm is apparently misconfigured somewhere (dsdt? BIOS? FC6?).

If I do:
#      cat /proc/acpi/alarm
I get a bogus return like:
      2007-00-00 00:00:00
even when I first set the alarm in the BIOS (or using nvram-wakeup).

If I set the alarm with:
#      echo "2007-03-17 16:30:45" > /proc/acpi/alarm
I can get the same value back when I "cat" it, but it isn't set in the nvram if I reboot and go into the BIOS to check it.
Craig Huff
huffcs at yahoo.com

----- Original Message ----

Have you tried to disable the set HW clock setting ?
Also, if your method involves writing to /proc/acpi/alarm do you write in the right format and do your shutdown script run with the right priviliges.

I use /proc/acpi/alarm on my a8n-vm cms with the HW clock setting disabled, setting hw clock on shutdown made wake up fail occasionaly.


On 3/17/07, 
Craig Huff <huffcs at yahoo.com> wrote:
To paraphrase Princess Leia: "You're my last hope."

I am using nvram-wakeup and Suspend2 to set the wakeup time and
shutdown my Fedora Core 6 system so that it will wake up when it is
time to record a show.

The pieces work, but not together.

I can use nvram-wakeup to set the alarm clock and confirm it is set in the BIOS.

can set the alarm with nvram-wakeup and shut down the system using the
front panel "soft-off" power button and the system WILL wake up at the
appointed time.

I can use Suspend2 to hibernate the system and recover on reboot.

I can use mythwelcome to invoke both of

However, when I do this, the system never wakes up at the time specified.

I have tried the suggested change to /etc/init.d/halt, but no improvement.

tried setting the alarm time twice with manual invocations of
nvram-wakeup (to the same time) followed by a forced shutdown (shutdown -n now), but no

FWIW, here is the debug_info from Suspend2:
Suspend2 debugging info:
- SUSPEND core   : 2.2.9
- Kernel Version : 2.6.18-1.2869_1.fc6.cubbi_suspend2
- Compiler vers. : 4.1
- Attempt number : 6

- Parameters     : 0 16 0 0 0 5
- Overall expected compression percentage: 0.
- Compressor is 'lzf'.
  Compressed 290709504 bytes into 145282452 (50 percent compression).
- SwapAllocator active.

  Swap available for image: 519908 pages.
- FileAllocator inactive.
- I/O speed: Write 81 MB/s, Read 105 MB/s.
- Extra pages    : 22 used/756.

The mobo is an ASUS A8N-SLI with an Athlon 64
 3200+ and 512MB.  I upgraded to this from a Gigabyte GA-7DX mobo I had planned to use because I had the same problem with it using FC5 and thought it was just too old/incompatible.

I would consider using a different distro, but based on Jarod Wilson's
website, I would expect that FC is suitable.  I find it hard to believe
that this new ASUS mobo is incapable of supporting ACPI suspension and
wakeup by alarm clock.

I am running out of ideas.

I've been struggling with MythTV since September and just about run out of patience.  If I can't get this working this month, I'll just have to give up on Linux and MythTv and go buy a Tivo because "it just works".

Any help would be appreciated.

Craig Huff
huffcs from yahoo

No need to miss a message. Get email on-the-go 
with Yahoo! Mail for Mobile. Get started.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070317/b080cb94/attachment.htm 

More information about the mythtv-users mailing list