[mythtv-users] Compile strangeness with svn 0.20.1.

David Watkins watkinshome at gmail.com
Wed Mar 7 12:26:19 UTC 2007

On 07/03/07, Graeme McClinton <graeme.mcclinton at gmail.com> wrote:
> I'm trying to compile svn 0.20.1 with DVB support enabled.
> When doing this the "make" step takes a lot less time than the "make
> install" step, and "make install" doesn't actually install anything.

Presumably make is failing.  Is there nothing in the make output to
indicate an error?
> When I compile without DVB, everything appears normal, with make taking a
> long time and make install being pretty quick, with working software at the
> end.

When you enabled dvb  in configure, did you also provide the path to
the include file?

> But I need DVB. Could this be a bug?
> I had a working setup, through ATrpms, but I made the decision to compile my
> own from svn, because of compatibility issues with a remote frontend I've
> just installed.
> I figured if I got stuck, I could always re-install the rpms from ATrpms. No
> such luck, he no longer carries them for FC4.
> Would it be possible to re-install from the cached RPMs? I've never heard of
> this being done, but I don't see why you couldn't.

The rpm install should work but, if you've ever started the SVN
version (you said you got the non dvb compile to work), then your
database has been upgraded and will [probably] be incompatible with
your rpm version.  If you've got a database backup then you could drop
the mythconverg database before you install from rpm and then restore
it from your backup.

More information about the mythtv-users mailing list